3.16 64bit install error on registering shell with Windows 11 Insider Preview (Dev Channel 25126, 25136, 25140, 25145, 25151, 25158, 25169, 25174)

Screenshot 2022-05-30 114955

Did you have a previous version in the program files (x86) folder?
Did you de-install that properly prior to installing as recommended in the notes?

I did have the previous 32bit version installed and uninstalled it before installing the 3.15 64bit and then 3.16 64bit versions. Both installs generated the error on integrating the shell integration. I am using Windows 11 Dev version 25126.

I have just uninstalled mp3tag and manually cleaned folders (including hidden) and registry of any mp3tag reference, rebooted and ccleaned. (I am a retired software support tech for a POS software and familiar with doing beta testing) Fresh admin install of 3.16 64bit and same issue ... program works fine but no integration with right click menus.

Installed on another PC running Win 11 build 22000 and 3.16 64bit installed with no issues (no previous version of mp3tag had been installed).

Hope this helps ... thanks!.

Does this help:

Maybe related to that but I haven't tried it yet. I've noticed that the UAC shield is still visible on the "Next" button in your screenshot. Can you re-try with allowing UAC access for Mp3tag?

I run with UAC on "Never Notify" and that was set while installing 3.16 x64. I disabled UAC via the Registry (EnableLUA set to 0) and rebooted. Tried a reinstall of 3.16 x64:

It's related to the Dev channel of the Windows Insider Preview. I've now finally managed to install this via Hyper V and can reproduce the issue.

I'm not sure where the bug is. However, given that it's working with the official version I'm tending to assume an issue with the preview version.

Thank you!
Should be a new dev version of Win 11 this week and I will test with that also.

Just tried a clean reinstall of 3.16 x64 with Windows 11 Dev version 25136 and still have the install issue of registering the context menu.

OK, thanks for checking!

Have you also reported that to Microsoft? I've also checked with the Beta version 22621.1 which still works as expected.

Edit: I've reported the issue via Feedback Hub to Microsoft at https://aka.ms/AAh7fez.

If you're on the Dev Insider channel, it would be great if you could upvote the feedback so that it gets some attention. From what I see, only very few Win32 apps do support the new Windows 11 context menu via a sparse package yet, so I suspect, very few others would report that.

1 Like

I have the same issue. I was running an older (V3.07) version, uninstalled, then installed V3.16a. I understand you already know this, just reporting it happens to me, too. Let me know if I can help resolve it, I'll upvote on Feedback Hub.

Staging Sparse Package Failed
C:\Program Files\Mp3tag
error 0x80080204 While preparing to process the request, the system
failed to register the windows.comServer extension due to the
following error: The Appx package's manifest is invalid.

1 Like

I'm also having issues with error when installing v3.16b and MP3Tag is also missing in Contextual Menu of Windows 11 Dev Build 25126. I would be very grateful if this can be fixed. Thanks

And? Have you acted as requested here:

1 Like

I've just successfully installed Mp3tag including the Explorer Shell extension using Windows 11 Insider Dev Channel version 25182. It seems like Microsoft has now fixed the issue that previously prevented the shell extension to be installed.

Can any other insider confirm the fix?

I can confirm the shell extensions are working with installing 317-x64 as a clean install on new Windows 11 Dev build 25188!

Looks like there's still an issue. When having the x64 bit installed and it notifies there's an update available it will download the 32 bit version instead of the 64-bit causing this same shell error when installing it.

Are you on the Windows 11 Insider Preview Dev Channel which this topic is about?

It simply opens a website with download options for 32-bit and 64-bit — it's not an automatic process and up to you to decide which version you want to run.

I just did a fresh format/install of Windows 11 Dev version build 25211 2 days ago. I also did a fresh install of MP3Tag 3.18 64bit with no issues. No update available yet to check this issue.