Actions before renaming


I've found out that 2.17c has the following problem (I'm quite sure, that I've seen it in earlier versions):

If I run actions before renaming files the unchanged tags (without actions) will be used for renaming.



Could you please give an detailed example?

Best regards,
~ Florian

I had the same Problem.

Tag: "artist" Filename: "artist"
after running Actions the tag is "Artist" (capital A). When now konverting tag -> filename the filename is still "artist".

btw: mp3tag allways says "10 files of 10 files renamed" even though the filenames keep the same. The same is true for safing tags. I think this was different some versions ago, was it?

sers, vitamin

I can't reproduce this here: I've changed the lower case tags entries of a file to mixed case via the Case conversion action set for the field _TAG and Mp3tag renames the files using the mixed case tag values at Filename - Tag.

I'll change this for renaming files, but not for saving tags (because Mp3tag doesn't compare existing tags with the tags to be written).

~ Florian

Which button do you mean by rename button?

~ Florian

[Tag - Filename]

Works fine for me too. Weird.

~ Florian

Could you please try to reproduce the problem with [link removed].

Thanks in advance,
~ Florian

It's still there!

I think it's a thread syncronistation issue which happens only on some systems.

Please try again!

Best regards,
~ Florian

Although the field now changes on refresh, the bug is still there in 2.18!

I know this, but after 2 weeks of trying to reproduce the bug, I had to release a new version because of other bugs.

I'll still try to find the bug :slight_smile:

~ Florian

The bug is now fixed in the latest Development Build!

Thanks to Flominator and vitamin for their support and help for finding the bug :slight_smile:

Best regards,
~ Florian

confirmed :slight_smile:

I might be able to help because I'm having the same problem. Let me start by giving background on how I ran into this same problem (with the Artist field not showing that it had changed case after applying actions.)

First, here is the final format that I use, in general, for all mp3's.

ARTIST ALL CAPS - Song Title Like This (Album Field Here For Version Of Song).mp3

The first step for me is .. by hand .. to change the filenames so they are roughly in that format (without the ALL CAPS portion). I've created a bunch of ACTION commands that help me finish off the formattting so there are no "_" or extra spaces and unwanted filename crap in the filename. After running the ACTIONS one time I end up with a filename like:

Artist All Caps - Song Title Like This (Album Field Here For Version Of Song).mp3

I then use the FILENAME to TAG command to insert the artist / title / album fields in their proper places. Each of them will be in Mixed Case (artist/title/album).

To get the ARTIST TO ALL CAPS I then apply the ACTIONS once again -- since there is an action command specifically to make all the Artist fields ALL CAPS.
This is where the problem arises.

When the action has run on all files and is complete, the Artist field still is Mixed Case. That is UNTIL I hit refresh, at which point the ALL CAPS shows up.

After refreshing, I then use the TAG TO FILENAME command to reformat the filename so that it reads like:

ARTIST ALL CAPS - Song Title Like This (Album Field Here For Version Of Song).mp3

If I do the ACTION command and DO NOT refresh, then do the TAG TO FILENAME command, I end up with:

Artist All Caps - Song Title Like This (Album Field Here For Version Of Song).mp3

Does this make some sort of sense?

Why do I want things formatted this way? It allows me at a glance to know that I've formatted the tags and I don't need to screw with a file that is in this format. It's worth the extra effort when dealing with as many mp3's as I do on a daily basis.

I'm downloading 2.18b beta and will let you know if it is still a problem with that version.



thank you for the detailed description! Could you please try this with the latest Development Build, because I think I've fixed the bug with this version.

Best regards,
~ Florian


Since this seems related I thought I'd highjack this thread. I've actions to replace special characters differently in a filename and a tag. After completion, the filename refreshes, but the tag data does not. Clicking on the file again shows the updated tag. Not sure if this considered a bug or not.



could you please send me the according *.mta file and the file Mp3tagError.log from Mp3tag's data directory?

Best regards,
~ Florian

Email sent. Thank you :slight_smile: