any way to remove itunNORM from comments?

Is there any easy way to remove itunNORM info from mp3s (this is itunes' Sound Check data)? It is stored as a second comment.

Deleting all the comments would lose manual comments I've added.

Is there any way to delete just the itunNORM comments? Is there even any way to filter so that I can see which songs have 2 comments?


I've made an action group to do it.
Extract the file to %appdata%\Mp3tag\data\actions to use it.

At first it merges the multiple comments to one comment field seperated by the ¤ sign (assuming you don't have that in your comments).
Then it removes the iTunNORM stuff and the ¤ sign. Your comment should remain.
Try it first on some test files..

Thanks so much.

I found another problem, though: it seems that if I make any edits to my files with mp3tag, mp3tag reorders the fields of the APE tag inserted by mp3gain, making the tag unreadable by mp3gain. Is there any way to stop that?

Thanks again.

What options do you have selected under Options > Tags > Mpeg?
Can you descibe in detail how to reproduce?

Editing a single file with ALT+T sorts the tags alphabetically, but on my tests mp3gain would still read the tags.

I did not change mpeg options, though I wasn't sure whether they would apply since this is an m4a or aac file, not mp3. But for mpeg, ape was not checked.

What I did: m4a files had previously been adjusted with aacgain (variant of mp3gain).

In mp3tag, I then right clicked the file, chose tags, selected the itunnorm tag, clicked the red x, clicked ok.

After that, when I ran aacgain, it did not recognize that the file had already been adjusted. You can tell this because it doesn't list a volume for the file. You can re-analyze and readjust, and since the adjustment was already made, the new adjustment will be zero. However, because the old tag was lost, you could not undo the original adjustment.

When I looked at the tag with an editor, I also saw that replaygain fields had been reordered by mp3tag.

I found out that the problem for aacgain is the upper case of the tag fields. You should be able to make aacgain read the tags again:
Go to Options > Tags and change the 2nd option (sry, I don't know the english name) to lower case.
Then just :mt_save: save the tag again.

Is this still the best way to do a bulk change to remove all these itunes generated comments? I tried to extract the file to %appdata%\Mp3tag\data\actions. In mp3tag, when I open actions, I don't see that this was added, even though user_Thornburgh.mta is in my C:\Program Files\Mp3tag\data\actions directory. Is there another step to make this action useable?

That's the wrong folder, %appdata% is a system variable
freedb and Web Sources

But this action is not needed anymore and probably doesn't work.In recent Mp3tag versions, itunes comments are separate tag fields that you can easily be removed with "View > Extended tags" [Alt+t]

thank you for providing this action for DL, dano.

the fields, not tags.

What can I do to prevent this alphabetical sorting ?