Can't make certain expression UPPERCASE

Hi...

I just can't make certain expression like "DJ", "NRG", "CD", etc in Filenames, Titles and Artists variables.

I'm using v2.45a

Thx for your help.

the question is a little cryptic.
Ifr you have a discrete amount of words that need a special treatment then you will have to create an action of the type "Replace".
you will need that for every tag and for every word unless you want to replace in _all fields (not advised).
E.g. Search for
dj
and replace it with
DJ
but make the search case sensitive and word-only.

A word of warning for the filename: apparently some operating systems do and other do not distinguish case in filenames. so best would be to write either only lower case or only upper case filenames.

Sorry... I was a little ambiguous. I followed the advice of the last post here :
/t/7341/1

I was able to make this part work with every tag I want :
ACTION »Format value«
Field: TITLE
Format string: $caps2(%title%,'/[(. -')

But, I wasn't able to make :
ACTION »Replace with regular expression«
Field: TITLE
Regular expression: (\W)(cd)(\W)
Replace matches with: $1CD$3
[_] case-sensitive comparison

...work.

I'm using Windows 7 Home Premium.

And, I'll try your suggestion :wink:

EDIT

...wait that was the same thing as I tried numerous time. So, the replace option doesn't work.

Tried that exactly :
Action : Replace
Regular expression : dj
Replace matches with : DJ
[X] Case sensitive
[X] Word-only

No, you did not try exactly that as you used an action of the type "replace with regular expression". In your search string there is no regular expression.
It is just a plain Replace.
So if you have fields that ask you to enter a regular expression, your action is of the wrong type.
The replace action only features the fields
Field
Original
Replace by
and the options for word only and case sensitive.

This setting requires a "dj" in the tag - a "Dj" would be ignored.

oups... my bad. The thing I tried WAS a replace

FIELD : TITLE
Original : dj
Replace : DJ
And ticked both cases.

But now that I retried it, I tried leaving both case empty and it worked!

Yay! :slight_smile:

Case closed!