Changing Discogs API key


Pretty self-explanatory question I've got here:
How do you change your Discogs API key on 2.65a?


Are you looking for this description: /t/15987/1 ?

Hi ohrenkino, thanks for your reply.

Unfortunately that isn't what I'm looking for.

The Discogs API key you enter in mp3tag is saved somewhere. Since there is no option in mp3tag to change this key afterwards (as far as I know), I want to know the location mp3tag saves this key to so I can change it manually.


Have you tried to rename the mp3tag.cfg file?
(I don't know where that key is stored - sorry). But as the cfg-file is sometime a good guess, it could be worth a try. If that does not help, you have to wait for a more competent answer.

I've deleted mp3tag.cfg and I was prompted to enter an authorisation key upon launching the Discogs utility. Thanks for your help.

A new problem arose however. After I enter a query and let the utility search, I am presented with an "empty" list of 100 results (see screenshot).

When I click a result, this error message pops up:

Do you happen to know a solution to this problem?


EDIT: I just tried again and I got a 401 authorisation error.

See this announcement on the 401 error:

There seems to be a workaround for some of the causes:

Issue persists, even though I've applied the workaround on 2.65a.


I have the same issue. Even after applying the workaround, I get an empty list with 100 results.

Fixed it by doing a complete removal and full re-install of MP3tag (I used to just update the installed version). Make sure you remove all the roaming\mp3tag folders.