Context Menu on Windows 11

Thanks for pointing. I'll look into it and check if it's possible to appear in the main context menu for a standard Win32 app.

1 Like

Well, is it?

I am interested if I have to stick to using Windows 10 for the time being on account of that caveat

I don't have a solution yet — it's quite possible for UWP apps or apps that are only distributed via the Microsoft Store, but I haven't found an option to register Sparse Packages from unmanaged C++ or an non-MSI installer yet. It's a whole new level of complexity.

From the implementation side, I need to use IExplorerCommand instead of IContextMenu which should be doable. But the registration part is tricky and unsolved.

I'd stick to Windows 10 for now (or use the "show more options" menu, which is not that comfortable).

Ok and understand - there does seem to be a possible workaround that switches the new context menu off available in WinAero Tweaker (and a registry hack as well) but not tried this - I'll give it a go in a VM or SandBox to see if it works and provides a workaround for now.

NO GUARANTEES WITH THIS but in general I have found WinAero to be safe, so worth a look for those interested How to Enable Full Context Menus in Windows 11

UPDATE I have seen that some others have managed to get this resolved Windows 11 Context Menu: How to Add WinRAR or 7-Zip in the Right-Click Menu noting that the 7-Zip (NanaZip) approach is via the store but WinRAR looks like it is a traditional approach.

A final thought: if the only way to do this is via the store, how about making your store-delivered version include the Windows 11 context menu (the only reason I don't use the store based one currently is that it does not install a context menu) and then you will have a version that people can choose (and get automatic updates from) that supports Windows 10 and fully supports Windows 11.

The really interesting information in your linked articles is the keyboard shortcut SHIFT + F10.
Without any registry or app change in windows 11, you get your old context menu back on every object if you press SHIFT + F10 on it. Without right clicking first, just directly press the shortcut.

Example for a folder on the Desktop:

First picture shows the compact original new Win11 context menu.
Second picture shows the context menu in full expansion, thanks to SHIFT + F10

Right click on a MP3 looking for Mp3tag:

Context menu after pressing SHIFT + F10

I've added support for the Windows 11 context menu with Mp3tag v3.10d and would very much appreciate any feedback from Windows 11 users.

Implementation Details

For someone who is looking into implementing this for their own shell extension, here is an outline of the steps involved in adding support for the Windows 11 context menu:

  1. Implementing IExplorerCommand
  2. Creating a sparse AppxManifest.xml with <uap10:AllowExternalContent>true</uap10:AllowExternalContent> and linking to the shell extension DLL from <com:Extension Category="windows.comServer">
  3. Creating the sparse package via MakeAppX.exe
  4. Signing the sparse package via signtool.exe and a valid code-signing certificate
  5. Implementing a custom installer library which uses PackageManager from Windows.Management.Deployment to register the signed package
  6. Adding means to unregister the package during deinstallation

I've wasted a lot of time on this, so if you're stuck in one of the steps please let me know.


In my Win11 test environment, both context menues looks nice, including the icon!

and with SHIFT + F10:

1 Like

Working perfectly for me.

It was an interesting read of the "rules" behind the new context menu on the Windows Developer Blog and was wondering if the context menu name "Mp3tag" would be more obvious if it were "Mp3tag Editor", "Open in Mp3tag" or even "Edit Tags in Mp3tag" - I was not 100% sure of the way the design rules are supposed to work and any of these would obviously then need localisation.

Just a bit of further feedback - although the new context menu works perfectly on files and folders in the right hand pane, the context menu does not seem to come up if you click on items in the hierarchical menu on the left hand pane even though it does come up with the "Show more options"...

I can confirm the finding from @AndrewM.

There seems to be a strange dependency between file extension, file type (maybe the defined standard app?) and a visible context menu entry. Also - for example - the left navigation pane shows not the same context menu for the same folder as you can see after a right click at the right pane.
This is not only true for Mp3tag, but also for VLC and WinRAR.

If you use a standard user account in Windows, the new menu does not appear, and also the option disappears from the general menu, having to manually open the program first and then drag the folder over the program to modify the tags of those files.

With the administrator user everything works without any problem.

Please fix this problem with standard user accounts, thank you.

1 Like

Thanks for pointing. Installing from a non-admin account (with necessary admin-elevation) should now be possible with Mp3tag v3.11.

I don't have the context menu appearing at all now with Mp3tag v3.11.
Does it require a system restart? I wasn't prompted.
I'm a bit busy at the moment to try a restart now, but I'll try later.

A restart resolved the issue in this case.

Yes, it did. Thank you, Florian.

When I right click on a track, Mp3tag opens it. But could I have it display all album tracks in that folder instead of just the one that I right clicked on?

OK, great! Seems like a restart is needed on some systems.

This is very straightforward: just choose Mp3tag from the context menu of the folder you want to load.

1 Like

I am running Windows 11 and the new context menu works fine in 3.11. However, would it be possible to also keep the old context menu? Why would I want this you might wonder. I am using Total Commander for file management which uses the old context menu where Mp3Tag is now missing on both audio files and folders.

After the update to 3.11, the context menu disappeared in Windows 11. The manual registration of the Mp3tagShell.dll fixed it for me. It does still only appear in the secondary menu (Show More Options) which is fine for me as this way it still shows in Multi Commander.

You could try this from a command prompt with administrative rights

cd <path to Mp3tag installation>
regsvr32 Mp3tagShell.dll

It worked great!

Thanks, and thanks for creating the best tag software out there.