Cover über Google


#1

Ich komme einfach nicht weiter und brauche Eure Hilfe:

Ich habe Pones Script, mit dem ich bei Google die Cover abfrage. Seit ca. einer Woche erhalte ich aber für jede Anfrage die Antwort:

"Es wurden keine Einträge zu Ihrer Suchanfrage gefunden."

Gehe ich hingegen auf "Bildersuche" bei Google, so bekomme ich vielfach ein Cover für meine Anfrage angezeigt.

Ich habe das Script vorhin gelöscht und nochmals hinterlegt, aber die Antwort bleibt gleich. Hat Google irgendwie geschraubt?


#2

Ja Google hat was verändert.

Falls du nicht warten willst, ich hab meine Version schon angepasst.


#3

Vielen Dank, Dano.

Edit:

Ich weiß, dass gehört sich nicht, aber der Mensch ist ein Gewohnheitstier...:

Gibt es die Möglichkeit, in dem Google-Script Suchparameter zu verändern? Ich erhalte bei den Anfragen relativ viele kleine Cover zuerst (75x75, 110x110) . Ich hingegen möchte gerne möglichst mindestens 500 x 500 und größer erhalten.

Habe ich ich das richtig gesehen, dass Cover Preview ausschließlich nach jpg.-Dateien sucht (was für mich genau das richtige wäre)?


#4

Ja man kann einiges mit den Parametern machen. Das steht alles in pone's Beitrag.


#5

Habe mein Skript jetzt auch upgedatet.

Dein Wunsch wäre dann ungefähr folgendes.

[IndexUrl]=http://www.google.de/images?q=%s&tbs=iar:s,isz:lt,islt:qsvga,ift:jpg

(= nur quadratische (iar:s) Bilder mit einer Größe über 400x300 Pixel (isz:lt,islt:qsvga) im jpg Format (ift:jpg)

Einfach das Skript mit einem Editor öffnen und die dritte Zeile unter der Überschrift SEARCH mit der hier im Beitrag stehenden Zeile ersetzen.


#6

Hallo Dano, hallo Pone, vielen Dank für die Mühe!

@Dano:

Meine Fragen im zweiten Beitrag bezogen sich ausschließlich auf Dein Script, bzw. Cover Preview 1.4. Dass es diese Anpassungsmöglichkeiten bei Pones Script gibt, war mir bekannt (ich hatte es vorher schon in Nutzung). Kann man diese Einstellungen auch auf Cover Preview / Script anwenden?

@Pone:

Vielen Dank für die Anpassung. Das werde ich ausprobieren.


#7

Hallo Pone,

seit ungefähr 5 Tagen erhalte ich wieder die permanenten "Es wurden keine Einträge zu Ihrer Suchanfrage gefunden"-Antworten beim Ausführen des Scriptes.

Gibt es zur Zeit etwas Neues? Und wenn ja, könntest Du das Script bitte nochmals anpassen?

Vielen Dank für die Mühe im Voraus.

Edit:

Ich habe das Script 4 Mal neu eingesetzt, um diese Fehlerquelle bei mir erst einmal auszuschließen.


#8

Ist mir auch aufgefallen in. Das seltsame ist, dass es dazwischen immer wieder funktioniert. Ich schau bei Gelegenheit was ich da machen kann. Aber wahrscheinlich erst nächste Woche.


#9

Klasse, ich dachte schon, ich hätte bei mir was unbewusst verändert.

Nur keine Hektik, ich überbrücke die Zeit mit der Amazon-Cover-Suche... :smiley:


#10

kommt heut noch, fast fertig :smiley:


#11

Erledigt.

Update 1.5:
[WS] Google Images Cover Search


#12

Jau, geht wieder wie geschnitten Brot. :w00t:

Vielen, vielen Dank, pone!!!

Ein schönes Wochenende!


#13

Hallo pone,

habe im englischen Thread die Aktualisierung auf Version 1.7 gefunden.

Vielen Dank dafür!

Ich habe eine weiterführende Frage zu dem Script:

Ich habe mich in diesen Thread eingelesen ---->: Artist Cover, Wallpaper [...]

und das Script abgeändert. Mein Vorhaben an dieser Stelle ist, dass ich gerne in den jeweiligen Interpretenordner ein Bandfoto als Folder.jpg haben möchte, da ich mit dem im Off-Topic stehenden Tool "Ordner-Cover für Windows 7" die jeweilgen Interpretenordner jetzt mit einen guten Ansicht verbasteln will.

Als Verzeichnisstruktur habe ich mal gewählt X:\Musik von A - Z\A\Axel Schweiss\Axel Schweiss - Mief

Mit "Utils" und dem Speicherpfad beim "Cover extrahieren" anpassen ist das eigentlich auch kein Problem.

Im Script habe ich hinterlegt, dass nach dem %Artist% gesucht wird. Nebeneffekt zur Zeit: mir werden nur Albencover angezeigt. In der Imagesuche von Google erscheinen hingegen viele, viele "normale" Künstlerfotos. Kann ich im Script hinterlegen, dass es bei der Bildersuche die Cover "ausblendet"?

Kann/muss ich an der folgenden Scriptstelle etwas ändern, um zu einer reinen Bilderansicht zu gelangen?:

# ###################################################################

A L B U M

outputto "coverurl"
sayoutput "currenturl"

Für einen kurzen Tipp wäre ich sehr dankbar.

Edit:
Ich habe jetzt nochmal gelesen (bildet!): In dem oben genannten Thread weist Du auf die Löschung in der "Indexzeile" hin (quadratisch, mindestens 400 x 300 px, nur .jpg z.B.). Nachdem ich alles nach [IndexUrl]=http://www.google.com/images?q=%s gelöscht habe funktioniert es wunderbar!

Sorry, ich sollte erst richtig lesen und dann posten... :rolleyes:


#14

Guten Morgen,

ich erhalte bei dem Script wieder ausschließlich die Meldung, dass keine Ergebnisse zur Suchanfrage vorliegen, obwohl die händische Suche Ergebnisse liefert.

Könnte die letzte Version (1.8) bitte nochmals angepasst werden?


#15

Ich weiß, funktioniert seit einiger Zeit nicht mehr. Bin noch nicht zum anpassen gekommen. Ein erster Blick hat mich etwas ratlos zurückgelassen, weil die debug Datei einen anderen HTML Coda anzeigt als wenn ich die abgerufened Seite im Browser anzeige. Im Moment hab ich leider wenig Zeit, könnte einige Zeit dauern wenn das komplizierter wird.


#16

Kein Problem. Schön, dass Du es überhaupt anschaust!


#17

Ich frage nochmal vorsichtig an... :smiley:


#18

Habs nicht vergessen...


#19

Es ist keine Lösung in Sicht.

Google Images hat vor einiger Zeit auf HTTPS URLs umgestellt. Diese können von Mp3tag nicht gelesen werden.

Sollte jemanden einen Weg kennen, die Google Bildersuche weiterhin mit einer herkömmliche http:// URL zu erreichen, könnte ich an einem neuen Update arbeiten.

Bis dahin, danke für die vielen Downloads und das positive Feedback, freut mich immer wenn meine Skripts gut ankommen.


#20

Ich wollte Dich absolut nicht hetzen!

Dir vielen, vielen Dank für die jahrenlange Erstellung des Scriptes und der ganzen Zeit, die Du darin investiert hast! :slight_smile: