Discogs authorization setup

Mod: topic split

Im sorry to bother you guys, but am i the only who cant authorize mp3tag for discogs?

:unsure: :unsure:

This is exactly the procedure I have done.
Cannot test again because don't know how to force discogs to request again the authentication code.

I can't get this to work either and previous attempts to ask for help both here and on discogs have led to people basically talking to me like I'm an idiot because I don't understand how to code. It worked once upon a time and now it doesn't, simple as that. I'd sooner stop using the software than be talked down to by people who obviously don't know the answer themselves, otherwise it would be working now.

Discogs forum can give you hard time and increase your blood pressure. I've faced myself arrogant and very irritating people there. You're not the only one.
Most of people here (including me) are just users like you and we are not "responsible" of program itself but we (try to) help each other without expecting anything in return.

Please make sure you install the new version (2.66) first.
I recommend you to:

  • Rename filename mp3tag.cfg in %AppData%\Mp3tag folder. Mp3tag program must be closed during this action. Start mp3tag after the change. Please send a reply if you don't know how to to this.
  • Test official Discogs script (named just discogs).
  • Search Discogs with a single word without any space or special character (e.g. Desperado)
    You will be asked to authorize discogs the first time you test discogs script.
    If you face error 401 then it's beyond my knowledge and only one man (Florian) can help you.
    Although if you succeed (that's very likely) then we know the rootcause of your issue is the search by.
    Try now with multiple words (e.g. Hotel California) and then with special characters (dot, dash, comma, etc).

After the test you may want to delete the new mp3tag.cfg (created automatically) and rename back the old file. You have to close mp3tag program during this action.
Good luck with your issue. I hope I did help somehow.

On the first attempt, I got the message 401, but the second then worked wonderful - thanks for the great tip!

I found that if I typed the authorisation code in it worked, if I copy and paste it
did not.

Followed your directions, not sure where I'm supposed to be seeing a 401 error, but I don't see it. It just comes up with the Authorization box in MP3tag which once again I don't have an authorization code for. Really really frustrating.

When the Authorization box comes up Mp3tag should also open the discogs site.
There you'll be asked to login and then you can authorize Mp3tag from your discogs account.
That way you receive the authorization code that you must enter in Mp3tag.

Mod: Post moved

I have just updated to 2.66 and over the holidays have been ripping lots of older vinyl albums to MP3, I tried to use discogs to tag and get this error. I've had a discogs account for a long time but never previously authenticated anything with it, including MP3tag.

I checked my https://www.discogs.com/settings/applications and there are no applications. What am I missing, I get exactly this problem :frowning: