Discogs error message

I'm getting an error message when using Discogs as a tag source. It doesn't matter if it's an ID search or the regular one. The error message says "failed to authenticate using OAuth(1)" and "401 UNAUTHORIZED". Is this something I can fix?

Please use the search function in this forum. The keyword 401 should be enough to get a thread like

It was new, so I scanned through topics for Discogs references, but didn't look deeper than that. Thanks for the link.

Have you already authorized Mp3tag via your Discogs account? If so, have you already revoked the authorization to trigger re-authorization?

Just to be sure: you're not using Windows XP and your system time is correct?

BTW, I've removed your replies to the other Discogs topics to keep the discussion of your issue with Discogs localized to this topic

I'm not using Windows XP and my system time is correct.

I did some keyword searching to figure out where to revoke the authorization (https://www.discogs.com/settings/applications if anyone else is lost and finds this thread). I got the error message, and nothing triggered the reauthorization. I dug some more and learned I need to rename mp3tag.cfg to make it happen, so I tried that and am still getting the error. I will dig some more in the forums to see if there is a better fix.

By the way, I've been using this software for a long time. It's become an essential part of my workflow as a volunteer music director for a community radio station. I'm a librarian by day, and I know that having clean and accurate metadata is essential to finding things electronically. MP3tag helps me do that with the crap files that get sent to us by promoters and record labels. I appreciate your help in getting the problems with Discogs sorted out (their data is essential for helping me fix the tags and other things), and I just made the donation I've been putting off and should have done years ago.

Is Mp3tag opening the Discogs authorization page in your browser in this case? Does the input dialog to enter the authorization code is displayed in Mp3tag then?

If not, maybe you're not renaming the mp3tag.cfg that is used by Mp3tag then. If you have a configuration file in the program folder (instead of %APPDATA%\Mp3tag), Mp3tag is using that one.

Many thanks for the kind feedback and your support! Personal thank-you email is on its way :slight_smile:

No, it's not. I just get the error message.

I've looked in the program folder and did a search of the entire computer, and the one in the %APPDATA% directory is the only one.

Is there a way for me to edit the mp3tag.cfg to insert a personal access token in the right place, which I'm able to generate on the Discogs site?

OK, I'm trying to get some more information. Can you please try the following:

  1. Rename %APPDATA%\Mp3tag\mp3tag.cfg to %APPDATA%\Mp3tag\_mp3tag.cfg
  2. Revoke the authorization at the URL you've pointed to above
  3. Try the default Discogs tag source from 2.90x again, and if the error message appears
  4. Make a screenshot of the error message and post it here.


OK, thanks. Can you now please send a screenshot of your system date and time?

Edit: And please also post your Windows version.

Windows 10 Education, version 10.0.16299 Build 16299

Looks good to me and I'm running out of ideas.

From the information you've provided, Mp3tag tries to get the OAuth request token via
and receives an HTTP error 401. This usually happens if an outdated TLS version is used (not your case) or if the system time is off (not your case).

Are you on some special network that might be blocked by Discogs?

Not as far as I can tell, and if it is, it's a new change. I was on my home network (Verizon FiOS) that I've used for a long time with no issues when it started, then at my parent's network in another state (Spectrum), and now I'm at a cafe nearby using their wifi (don't know the provider), and getting the same error message. I uninstalled and reinstalled the program yesterday as well.

Update: I gave this a rest for a couple weeks, and today tried again. This time, it took me to Discogs to reauthorize. I wonder if I was trying too frequently before and hitting some sort of security block as a result?

1 Like