Extra characters in columns if library is activated

now without library

I just checked with my 3.18d and that does not show any extra characters in either state of the library.
I have a standard installation on W10.

If you enlarge the left side Tag panel - so we can see the complete Directory field entry - how does it show the complete path there?
Once with enabled library and once with disabled library?

Even after deleting the database file mp3tag.db3 and rebuilding it the problem still exists:

1 Like

Honestly, I haven't got the foggiest what could cause this.
A messed up cfg file?
A strange column definition?
If you have anything else than switching on an off the library to reproduce the phenomenon, please tell us. Because right now I simply cannot reproduce it.

I have the same issue after installing the latest development build, 3.18d.

1 Like

The filename of your song #9 "09 Dust.mp3o3" seems to suffer from this extra characters too. Strange thing.

What exactly do you use as definition for your column "Kurz-Pfad"? (Right-Click on column header, "Customize Columns", Value and Field definition?)

I see it now - for some of my songs, not all - too:

I just have loaded some songs with an existing, previously builded libary. Many songs appear correct. Some of them have this extra characters.

If I scroll through the list with extra characters (pressing KeyUp), they disappear for every "touched" song for the TITLE or ALBUM, but not for the Filename.

The extra characters seems to be random:

My definition for the Filename column:
image

1 Like

After "repairing" some columns by scrolling through the list with page-up or down you may press f5 to reload the screen and you will have the unwanted extra characters back.
Here is another example

The problem seems to be in the library generating process. If I throw the library away and go back to v3.18 the problem goes away also.

Now I saw it also. Sorry for the disbelief earlier.

Many thanks for reporting!

I've just released Mp3tag v3.18e which should fix the issue. Please let me know, if it works for you with the library enabled.

It's now displaying correctly for me with 64-bit. Thank you!

1 Like

Not instantly. I had to delete my library mp3tag.db3 to get rid of this extra characters.
Maybe a cleanup would do it too? It could be that only users of 3.18d are affected?

The issue was related to handling the values after they were read from the database.

So deleting the library should not make any difference — once the extra characters would have been stored in the library, you'd also see them in the actual metadata of your files (and they wouldn't vanish if you delete the library).

Do you still have the mp3tag.db3 which shows this?

No, unfortunately I did not save it away.

I had not written any of the corrupted metadata to my mp3-files, because I was only browsing for songs (composed by the late Christine McVie) to generate a playlist. Therefore going back to a previous version AND removing the database file plus regenerating it from scratch did remove the extra characters also.

Does using v3.18e fix the issue also for you?

Yes it does, I did not observe any of the extra characters any more with v3.18e. Thank you for your prompt fix.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.