Failed Authentication to Discogs

Same problem here. Same error 12029 12029 with Discogs. MusicBrainz doesn't give results for any simple words or phrases used. FreeDB still functions.

see this thread on the 12029 error:

Which OS do you use?

Same problem here starting today. Same error 12029

To fix the MusicBrainz issue, edit your MusicBrainz.src file and replace all instances of "ext:score" with ":score" and save.

The Discogs OAuth (1) issue is till ongoing.

Are you using Windows XP by chance? Discogs disabled TLS 1.0 and 1.1 for, so Mp3tag no has to use TLS 1.2 for connections to

Unfortunately, TLS 1.2 is not supported on Windows XP, so you'd need to update your OS to use the Discogs tag source.

I'm using Win7 Prof.

TLS 1.2 has to be enabled manually on Win7. See

Works for me :slight_smile:


I've just released Mp3tag v2.88h Development Build, where I've enabled TLS 1.2 by default for HTTPS connections (also for Windows 7).

Enabling TLS 1.2 manually should not be needed anymore.


"Good News, everyone!" Version 2.88h corrected both of issues that I was experiencing: Discogs works again, after reauthorization, and MusicBrainz has started returning results again.


Oh dear... I was breaking my head as to why I couldn't connect to discogs any more.

Glad I've found this topic as v2.88h does in fact fix it!
Thank you Florian for bringing this update so fast :+1:

PS: made a €5 donation yesterday via bank transfer. I've included my email address in the comment in case you want to reply (not mandatory though).

Glad everything is working again. Yay!

Hi there,

since yesterday the program can not connect to musicbrainz and discogs.
This error is displayed when connecting to discogs:

this one is showing when connecting to musicbrainz:
And there i wonder too because it shows :"searching in $regexp(album..."

I reinstall the program. Rename some files in the program folder, delete the authentication on the discogs page. But the issues are the same.

Mh, thats all strange

The older versions don't work any more. (You are still using version 2.88a).
You need to download v2.88h

But nothing change.
Same issue.

Musicbrainz shows "87: Open Failed" and the Window shows (like in the picture above) ""searching in $regexp(album...""

Discogs shows the same and "Failed to authenticate using 0Auth(1)

I use Windows Vista, which is my main operation system.

On the second Windows 7 it works with no problems.

According to Mp3tag Development Build Status this should be fixed for Vista too. I'm not sure, if this is really true for Vista (out of MS-Support since 11. April 2017).

I haven't tested in on Windows Vista and thought that setting TLS 1.2 on the connection works there too (it should according to this table).

Edit: I've now tested it on Windows Vista, it doesn't support TLS 1.2.

1 Like

I have enable the TLS 1.2 but it doesn't work.

i installed the windows server 2008 update and changed the registry after a guide i found (maybe it was the wrong), but nothing change.

So mp3tag will not work anymore on vista?

Mp3tag still works on Vista, but the Discogs tag source can't be used anymore on Windows XP and Vista due to missing support for TLS 1.2.

Hi Florian,

Thanks for responding to our problems. I have installed 2.89a and it all works again. :slight_smile:

Regards, Brian.