FLAC - Composer issue with semicolon separator

Hi,

I have been having difficulties displaying the composer properly info when using various music apps with music files ripped using dbPoweramp to FLAC lossless.

The same music files were ripped simulteously to ALAC and LAME.
Do not seem to have an issue with LAME but with FLAC the composer info only displays the last composer if multiple composers are in the composer field.
I have 50000 tracks of which about 95% the metadata for the composer field is usually in the form using a semilcolon and a space
for example
Jimmy Page; Robert Plant; John Paul Jones; John Bonham
The others are in the form
Jimmy Page/ Robert Plant/ John Paul Jones/ John Bonham
The forward slash tracks display correctly where as the tracks with semilcolons only display the last person mentioned in the composer list.
I can change tracks from semicolon to a forward slash to fix this.
I was pointed to your site by dbPoweramp as a possible solution..
Probably the multiple artist info has the same issue of being separated using a semicolon.
But with 50000 tracks I was wondering if this mp3tag program to do a batch job only to change the semicolon to a forward slash for all my files without destroying any file integrity...?
Hopefully I have explained this properly / makes sense?
Regards
Steve

The problem is that of your player which apparently interprets "semicolon blank" as a separator. (I know that WMP does.)
At least WMP displays all entries in the track list and only separates the fields for the sorted list of individuals.
But your question was: how to replace a ; with /

Create an action of the type (simple) replace for COMPOSER
Search string: ;
Replace string: /
(add the appropriate number of blanks where you need them. The forum editor does not show them properly)

Do the same for ARTIST if you want to replace the ; there as well.
Here is some more help on actions: /t/967/1

Most likely you are correct

I have been using semicolons as separators and with spaces- in the exact form that you DTW have described. And I have not noticed a problem of data not showing up or disappearing in regard to FLACs, which I have been using for almost 4 years now. That is not showing up in Mp3tag- as in Winamp I had run into some issues of that kind [and having to adjust my system to combat them away]

And just to be sure I loaded my FLACs to Mp3tag and checked the COMPOSER field- and I have plenty or examples of correctly semicoloned data in that field

Thanks for your responses. Appreciated.
I managed to use under Actions tab ---. Quick Actions
Then choose Composer and the put in a "/ " forward slash space
And the same for the Artist section.
Did this for all tracks but it seemed not to like doing any more than about 5000 at a time.
Now the HiFi Cast app displays the multiple composer info.
From what I have seen online although the players should accept a ; or a / a lot of them do not especially apps for you phone etc.
Maybe most people are not too interested in who the composer is..
So I am assuming at this stage I have gone down the right path.
Have kept a backup of the unchanged files just in case.
One other thing that may be nice for the mp3tag would be a search facility ( unless there is one I cannot find)
Thanks gain.

MP3tag has a filter.

Not sure if I am using the filter properly but it is not very easy to find a particular searched item
ie like trying to seach for something like eg "zap"...
Also Does it matter if the separator is in the form of
either ";" or "; " or " ; " or "/" or "/ " or " / " ?
Also does it matter if which separator is used for ALAC or FLAC ie can either a semicolon or forward slash be used for either?
Or does it depend on the player?
Thanks

What have you entered in the filter box?
e.g. if you just type zap then you should see all the files that have zap somewhere in the tags or properties.
The thing about the separator: yes, that depends a lot on the player.
Windows Media Player interprets semicolon-blank as separator while iTunes does not.
And it has to be semicolon-blank - just semicolon does not work.

Sorry to have to go back to my original issue.
Just wanted to check whether I used the correct method to change the separator from a ; to a /
After selecting the tracks I wanted to change

  1. I went to actions then quick actions
  2. I used the option "merge duplicate fields"
  3. Chose field as "composer"
    4.then put in my separator as " / "

I was wondering if instead of selecting the option "merge duplicate fields" I should of used "split by separator"
Thinking now maybe I should of just stuck to ";" as the multi field separator as in the orginal rip because by using the / all that I have appeared to of done is make the composer metadata one long word as the / is just seen as another character in the name ?
ie
Jimmy Page / Robert Plant / John Paul Jones / John Bonham
versus
Jimmy Page; Robert Plant; John Paul Jones; John Bonham

when I do an Alt T on the track it displays the meta data differently
eg for the / it just lists 1 composer ( Jimmy Page/ Robert Plant/ John Paul Jones/ John Bonham )

whereas when a semicolon is used it lists the composers as
Composer Jimmy Page
Composer Robert Plant
Composer John Paul Jones
Composer John Bonham
etc
Added after the above...
I'm now wondering if its best just to convert the composer metadata back to a "; " ( semicolon + space ) as it was originally and just find a music app ( or NAS or whatever ) that can handle it properly.
Just looks like all I've managed to do is to make one giant composer name where multiple composers are involved by using a forward slash to separate the names.
If I go to the trouble of using mp3tag to change all the composer and multiple artists files back is "; " ( semicolon + space ) or just a semicolon on its own ";" (with no space).
the way to go for both FLAC and ALAC
Or just a semicolon on its own ";" with no space
Maybe should of left well enough alone in the first place.
Was thinking of
Using quick actions to do a replace of a "/" for ";" for the composer and artist metadata
Not sure whether to use just a ";" or "; " ( "semicolon" versus "semicolon + space" ) as the separator
Thanks

This stuff with several fields of the same type can really be confusing as apparently every player has its own way of dealing with it.
As this is the MP3tag forum, it may be best to show what MP3tag makes of it and then see what other programs do.
MP3tag can deal with "multi-value fields", i.e. several fields of the type COMPOSER, each with different data in it.
In MP3tag you can check the definition for the column for COMPOSER and you may see this entry for
"Value": $meta_sep(composer,\)
This means: if there are more than one field of the type COMPOSER, then show them all but separate the contents with "\".
For MP3tag the \ is the default separator to create multi-value fields.

You have mentioned that other programs use the slash or something with semicolon as separator.
This may well be - but has usually nothing to do with multi-value fields. The data for a field is stored in just one field (e.g. of the type COMPOSER) but the other program interprets the data and creates separate entries in its own database.
You can see this behaviour in WMP where you see just the individual names in the Composer list but see the whole field contents when you look at the individual track.
iTunes does not use the semicolon-blank mechanism but displays such a COMPOSER field just like MP3tag: as just one field with several names in it, separated by semicolon-blank.
Other players may like other separators.
Other player may not like real multi-value fields.
In the end it could be that if you use different players, the use of a single separator or field scheme is impossible as each has its own variation of implementation.
Yet, with MP3tag you can easily merge multi-value fields, split fields, replace one single field separator with another.

Thanks,
WMP...iTunes..no one I know who like quality would bother ...seriously
At present I just want to know how to get my Composer and Artist fields back to the way they were before I made the mistake of using mp3tag.
Before in my metadata they were composer1; composer2; composer3 etc
As with the Artist
artist1; artist2; etc
Is there anyway back to my original files?

Then show us what the files look like now and what they should look like after the treatment.

Thanks..sorry for the delay.
I managed to go through all my tracks and using actions got all my tracks back to how they were.
with the composer fields separated by a ; and the artist fields separated by a \
When I look at the metadata it looks how I would expect,


But still my music players wont display the multiple composers.
I found that the only way I can get this to happen is to also do a Merge and I used a ; as the separator.
Now in the music player it displays the composer info as example:
Jimmy Page;Robert Plant;John Paul Jones;John Bonham
Am I on the right track or just made one long composer name?
After doing the merge the metadata for composers display in one line as
Composer: Jimmy Page;Robert Plant;John Paul Jones;John Bonham
Tried to attach a second image but the forum would not let me.
Thanks

I think that you are on the right track and the question should end "and just made one long composer name" (not "or").
You see the dilemma that only very few players can deal with multi-value fields. That is why you see only one if you use that feature.
If you merge the multi-value fields to just one (and get one long string), then you get the phenomenon that some players split this long string into separate entries and others leave it in the original long form.
And then there are players that can deal with multi-value fields but show them as a merged long string.
And there are players that use the long string for one kind of display and the split one for other views (WMP does).
WMP does the split
iTunes takes the long string
foobar can deal with multi-value fields.
And MP3tag can help you to get the best solution for the abilities of your favourite player.
(BTW: for players that split strings, it would be "semicolon-space" as separator)

Thanks for the fast response.
So for Composer I will do a merge with separator as "; "
Should I do the same where multiple composers are in the data?
Also will this impact my library long term too much? ie by doing this will it screw it up or will I be able to get back to multi composer as in the form its in now?
Thinking about doing a batch job tonight with the merge.
Thanks.

You can either use an action of the type "Split field" or replace the "; " with "\" which is the indicator for MP3tag to create multi-value fields.
So it should be reversable.

Thanks again. Much appreciated.
Just double checking on the artist tag
Currently they appear in mp3tag as backslash backslash "\" and appear in the windows properties as "; "
Is "; " the best separator if I do a merge on this as well?

For Windows: yes (and for WMP)

Thank you.
Tried it out using Hi Fi Cst, Mediamonkey, Foobar mobile, mconnect HD and see how it goes.
Composer info appears to be ok in Mediamonkey and HiFi Cast.
Seems to try it and see as far as players are concerned.