Found existing installation error


I'm using mp3tag since... ever. And love it of course.

Now i can't install the latest version (3.21). Neither 64- or 32-Bit. The error message "found existing 32-bit (or 64-bit) installation..." appears.

But i already deleted my previous installation and folder. Even the ...\AppData\Roaming folder.
However the Mp3tag (v3.19) app is still shown in Windows>Settings>Apps. When trying to uninstall. here it also says "Can't find C:\Program Files..."
(I'm using Windows 11 Pro)

Any idea what i can do solve this?

many thanks!

Doesn't the un-installer ask whether you want to remove the installation anyway?
And if so, what happens if you agreed?

Which one?
There is no Mp3tag Uninstaller left. The whole folder C:\Program Files\Mp3tag is removed.
If I try to uninstall via Windows>Apps it says "Can't find C:\Program Files\Mp3tag\Uninstall.exe"

And doesn't it then ask whether you want to remove the application?

No. It looks like this. If i confirm with OK, nothing happens.

have you tried to install the old 32-bit version? So to restore the program structure?

That's the message from the installation menu:

And here if i try the 32-bit version:

I don't know what the new installer exactly checks to return the above error messages.
But could it be that you have Mp3tag leftovers in your Windows Registry (or did you removed them also manually already)?

No, i haven't removed anything from the registry manually yet. Which RegKey would it be most probably?

For example:


Ok thanks, i searched and removed every "mp3tag" entry in my RegEdit manually.
...It worked! Installation was successful, program is running and I'm tagging again :wink:


This happens if both the 32-bit and the 64-bit version are installed.

In this case, the easiest solution is to just uninstall the "active" version via Windows Settings → Apps & Features and then run the installer again. If it still complains, you need to install the version with the different architecture.

Deleting the installation files manually (including the uninstaller, which is not recommended) added the extra difficulty in this case.

Thanks for your answer, Florian!
I even tried using the Mp3tagUninstall.exe before i deleted anything manually. For some reason it always brought the error saying "Please close mp3tag first"
But the program wasn't running for sure. I checked all processes in the task manager and even restarted the PC.
Maybe i really damaged something with a previous installation or so. Anyway, now it works fine as ususal again.


1 Like

Happened to me too only on this version for some reason; never had the issue before despite the same factors being involved, but Florian's solution worked perfectly!

This program is a god-send, keep up the good work :slight_smile:


I had to do this too(which solved the issue).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.