Horizontal jump in table after saving a data

Salut all!

Win7x64hun, last Mp3tag. But, on my older computer with WinXPsp3, the situation is the same; and already some years (I can not remember, was anywhen Mp3tag without this bug or not).

Standard view with the table, details panel on the left; on the top: menu, menu buttons, filter bar. Both the table (53 columns) and the details' panel (26 data fields + the library selector) are much bigger, than in the original view. In the table there are opened 2 or 2 thousends files, MP3 or FLAC or both - no matter.

Horizontal scrollbar is displayed, of course. The thumb is about on the 20% from the left, on the scrollbar. (The scrollbar width is about 5× bigger, than the thumb's, so this is the "second click" on the scrollbar, from the left.) The cause: here displayed the "Title" column (for identifying a file in the table).

1 row is selected. I modify some data in the panel, then select the second (any) row. At the same time the previously modified file's datas will saved (by my settings). After selecting the new row, the horizontal thumb jumps to the very left (starting position) of the scrollbar. Of course, it is very annoying.

The situation repeats not every time, only about in 70-80% of cases. It happens after modifying multiple rows at once, too. The computer is not busy, resources are enough.

If somebody has this bug too, it will be nice to know about.

Nobody has solution? :frowning:
Have anybody this bug, too?

I have never noticed this before and I tried to reproduce this for half an hour.
Indeed I had this effect one time but after that I could not reproduce it any more.

Poster, thank you for trying.

In addition:

  1. It happens only if I edit a data in the details panel on the left. After editing in the cell, happens nothing.
  2. If after editing in the panel, before selecting the (any) next row I drag the horizontal thumb with the mouse and move it a little (1 mm is enough), then happens nothing.

I've also tried to reproduce this in different versions of Windows – so far without success.

Kind regards
– Florian

Florian, thank you too.

I found a (not very nice, but working) solution: now I save changes not simply by selecting an other row, but first clicking on the "SAVE" button. I can live with it. :smiley:

Can not understand, what is this mystic bug, only on my PC...

Ceterum censeo... thank again for the brilliant program! :smiley:

By the way, did anybody try it with so big table, as my? Table: 53 columns. Panel: 26 data fields + the library selector.

I think this has to do with some kind of repaint-event.

E.g. you remove a filter and the file list gets redrawn
I have experienced this jump back when saving data on external drives when the writing of data takes a little longer and MP3tag does not respond for a minute period of time.

It might be worth investigating if this happens on network drives and local drives equally often or if it happens more frequently on external storages (network, usb).

Uuuh yes: it also happens, if for some reason or other you type in data but the corresponding field has not got the focus yet. Then the keyboard input is interpreted as some kind of search and you get the table redrawn and repositioned.

Thank you, ohrenkino. So it's not my computer's fault; and it seems (for me), you localized the cause.

Oops! Ohrenkino, you gave me an idea. I closed the filter bar, and now I can not reproduce the phenomenon.

Edit later
After an hour working it started again the previous behavior.
(As I remember, in same time, when my laptop's ventillator started to work on more high frequency. But CPU's loading is still about 10-15 %, RAM on 45%.)

Edit, second
Undoing changes provokes this behavior, too.

This is now fixed with Mp3tag v3.05a. Thanks for reporting, many testing sessions via email, and the patience.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.