ID3v1 genre number written by iTunes is not translated for ID3v2.4

Strangely enough, I have noticed recently for mp4 files where the genre is updated in iTunes, mp3tag then refers to it only by the number. In the tag panel for this example, it lists 98 instead of the expected Easy Listening entry.

Yet if I edit this in mp3tag back to Easy Listening, it still shows correctly in iTunes. I don’t recall seeing this behaviour in the past. Is it something that iTunes could be writing incorrectly?
mp3tag version 3.16b and iTunes 12.12.4 on Win10/64

Your screenshot shows MP3 files and you refer to MP4 files. I've now tried with both MP3 and MP4 and could reproduce this for MP3 files tagged with ID3v2.4. Can you double-check regarding your observation with MP4?

Changing the genre via iTunes writes the ID3v1 genre number instead of the genre text. It uses the format (##) for ID3v2.3 — for which Mp3tag's ID3 implementation has special handling, but ## for ID3v2.4 — which is currently not supported by Mp3tag (but allowed according to the standard).

I've moved that to #bug-reports, will work on that and keep you posted.

My bad on posting that particular screen shot, I was actually trying it on a few files, and didn’t notice that I had changed to a folder using mp3. But the same behaviour happens with mp4 files.

Another strange thing though was the fact they had v2.4 tags as I have not made this change that I can recall. I wonder if Apple made that the default in a recent update to iTunes?

OK, thanks! I've tried this with a m4a file without tags and couldn't reproduce it. Are the files from a different source, or are you sure they're tagged/created using iTunes.

Yes, I intentionally made the changes and saved in iTunes to reproduce this. These are from files I ripped from my own collection. I don't use mp3 format any more, and have slowly been re-ripping these into lossless. I use dbPoweramp for all of my ripping.

I changed the iTunes default back to v2.3 and mp3tag handles it properly again for not just mp3, but also mp4. I didn't think id3 should have an influence on mp4 files, but iTunes must be doing something with it in the background.

I think I can't reproduce the MP4 issue for now. Can you send me one of the MP4 files that shows a genre number?

As background information: MP4 tags have two different ways of writing the genre

  1. Standard genres (as known from ID3v1) are written to the gnre atom and are translated by Mp3tag in both directions.
  2. User-defined genres are written to the ©gen atom and should not use the genre numbers but the textual genre representation.

Now I can't replicate it with mp4, but still for mp3. If I can find it again I will send a file.

1 Like

This is now fixed with Mp3tag v3.16c. Thanks again for reporting!

1 Like

I have tried making the genre changes going both ways from mp3tag to iTunes, and back. Using both ID3v2.3 and ID3v2.4 works flawlessly now.

And for the record I still cannot get this to occur now with mp4 no matter what I try. Perhaps I was mistaken when I saw the issue in the first place, and it only happens with mp3 files. So apologies for sending you in search of a problem that doesn't seem to exist with mp4.

1 Like

Thanks for confirming the fix and no worries regarding MP4: it's still possible that some application writes the genre number that should go to the gnre atom to the ©gen atom which should only contain the custom genres.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.