ID3v2.3 tags to ID3v2.4 tags due to character display problems on Android

Hello, I have a problem with tags. My SamsungGalaxyA50 Andriod11 One UI 3.1 in Samsung Music probably can't process ID3v2.3 tags. When I move songs from my computer to my phone I always see weird letters. I'm from the Czech Republic and we have a bit of specific letters in our alphabet, but even so, it worked for me until recently. I noticed that my phone probably only supports ID3v2.4 tags. Unfortunately I don't know how to convert ID3v2.3 tags to ID3v2.4 tags. I have Mp3tag software version v3.06a. Please advise. Thank you for the solution.

This is astounding as V2.3 tags are supported much more widespread than V2.4.

Check File>Options>Tags>Mpeg which kind of tag version you write. Preferably, this shows V2.3 UTF-16.
If it shows V2.3 ISO ... then the characterset requires a specific code page.

A remedy would be to load the files and then press Ctrl-S to save the tags (again) but this time with the new encoding.

1 Like

I tried your solution, but unfortunately it doesn't work. I have this on in the settings: picture Snímek obrazovky 2021-04-08 154025

If you insist on V2.4 tags then you can change the tags to a different version wth the other options. So for V2.4 set write to V2.4, load the file and then press Ctrl-S to save the tag in the new version.

If you add a column with the setting for
Value: %_tag_read%[ (%_tag%)]
then you can see in that column which tags are in the file and which one you see.

1 Like

I think don't understand your solution.
If I choose ID3v2.4 UTF-8, my album art will not load, but the characters are correct.
If I choose the ID3v2.3 UTF-16 option, it will write weird characters.
If I choose ID3v2.3 ISO-8859-1 it will change the accent of the characters.
I've tried reinstalling Mp3tag several times and nothing helped.

Where do you see the weird characters? In MP3tag?
You could try an action of the type "Convert codepage" to get from the local codepage to a more international format.
ID3V2.4 has a cover but I don't know if you have written ID3V1 tags previously. What does your extra column say about the tag versions in the file? If there are V1 tags then it could be that your player does not understand V2.4 tags and reads the V1 tag instead which has no cover.

1 Like

Everything is fine in Mp3tag, I see everything correctly there. Only when I switch to ISO-8859-1 do the diacritics disappear. The problem occurs when I move a song to my cell phone. Then everything changes on the phone. The picture shows a sample. I had the music in Mp3tag set to one album (UTF-16), but after transferring the music to my mobile phone, it was divided into three albums with strange names. What do you mean by the "Convert codepage" action?

If the files look good in Mp3tag, there is no need to convert the codepage. It's simply your phone not supporting the ID3v2 standard to it's full extent.

This is promising. Maybe your player simply doesn't understand unsynchronization. I have an update in the pipeline, which you might try later.

Until then, there is very little to do :slight_smile:

1 Like

It's weird because it worked normally a week ago. :grinning:

With the ID3v2.4 UTF-8 option or something different?

1 Like

You can try again with Mp3tag v3.06c and ID3v2.4 with UTF-8.


Is there also the same top version in the Windows Store that I can download from your site? (I don't mean beta)

Just for the record:

č is U+010D, i.e. 0x010D in UTF-16 and 0xC48D in UTF-8.

U+00C4 is Ä and U+008D is the invisible control character REVERSE LINE FEED, which may be rendered as a crossed-out box. ISO 8859-1 is the same as Unicode for the first 256 code points, but it is of course limited to 8 bit/character. 0x8D can safely be treated as unassigned there, and coincidentally it is also unassigned in Windows-1252, which does reassign most neighboring 8-bit codes.
So what’s happening in the upper left picture is that UTF-8 text is displayed as if it was encoded in Windows-1252.

Ť as seen in the upper right picture is U+0164, i.e. 0xC5A4 in UTF-8. It is also available as 0xAB in ISO 8859-2, but as 0x8D in Windows-1250. This means, UTF-8 is treated like Windows-1250 in this case.

Hi, I have similar problem. I´m using Pixel 2 and JetAudio+

  1. If I choose ID3v2.4 UTF-8, my album art will not load, but the characters are correct. But, when I use for editing TagScanner 6.1.7, I see album art correctly.

  2. If I choose the ID3v2.3 UTF-16 option, I see weird characters in JetAudio+. If I tried VLC player, characters were correct. Probably it´s due to bug in Android media scanner.

Tags written by TagScanner:

Tags written by Mp3Tag 3.06a:

If you check closely, you will see start of the image in the left upper corner.

I try to edit in Mp3tag 3.06d and problem is solved. Thank you.

Excellent! It's probably due to this change:

CHG: not using ID3v2 unsynchronization scheme anymore when writing ID3v2.4 due to compatibility reasons with apps that don't implement the standard.

More details here:

Hi, I finally managed to get the correct display of characters and images. In Mp3tag, I deleted all tags in all songs, including pictures. I left only the names of the songs themselves. When everything was deleted, I added tags, but using the name-tag function. Then I added pictures and it was done. I deleted everything and saved it in utf-8 format. And the Mp3tag version I have 3.06d. Version link: Mp3tag Development Build Status

Ahoj, mě se nakonec povedlo dosáhnout správného zobrazení znaků i obrázků. V mp3tag jsem vymazal všechny tagy ve všech skladbách včetně obrázků. Nechal jsem jen názvy samotných skladeb/souborů. Když bylo vše smazáno zase jsem doplnil tagy, ale pomocí funkce název-tag.. pak jsem přihodil obrázky a už to bylo hotovo. Vše jsem mazal i ukládal ve formátu utf-8. A verze mp3tag mám 3.06d. odkza na verzi: Mp3tag Development Build Status

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.