Info in the "Comment" field not showing in iTunes

I have a large collection of MP3 files, many of them containing valuable information in the "Comment" field. My problem is that when I transfer the files from my Windows computer (where I use MP3tag) to my Mac Mini running iTunes, all the information on the "Comment" field is lost. I searched the forums for help on this but didn't find the answer... :frowning:
I'm using MP3tag v2.49 (in Spanish) on a netbook running Windows XP (also in Spanish).
Can you please help me with this?
Thanks in advance!

Are you sure your mp3tag is set up correct, right click where it says title, artist, genre etc >customize columns and you should see the attached picture with %comment%

As far as I know (and I found a corresponding German thread) does iTunes require an English comment field.
MP3tag writes "comment" in the set language - probably "Spanish" for you.
You can change these settings like follows (translation from dano's post):

-close Mp3tag

-open installation folder for Mp3tag.exe and navigate to folder "lang"
e.g. C:\Programme\Mp3tag\lang\

-look for your language file - it is "German.lng" for German, so for you it is probably Spanish.lng and open it in an editor

  • search for line _M_STR_ID3V2LANG
    Following that there is the ISO code for language (3 characters)
    eng = Englisch
    deu = Deutsch
    spa = Spanish (?)

Edit this value to "eng"
Save the modifcations, start mp3tag, try it.