Issue album art image and ID3v2.4 UTF-8

Mp3tag v2.70
Windows 7
1 album with 10 mp3 files.

Current Issue ... Default Mp3tag settings for Mpeg is ID3v2.4 UTF-16. However when I set/save to ID3v2.4 UTF-16, Vietnamese language displays as squares/weird characters on my smartphone. No problem with the album art work cover image showing up. Instead 1 album showing on my smartphone "Galaxy S4", it shows multiple albums from the same album because due to Vietnamese language displays as squares/weird characters.

Mp3tag options 2 is to set ID3v2.4 UTF-8. However when I do that, I have had no problems with Vietnamese language displays, no funny squares/weird characters. But most of all, my Mp3 files are embedded with album art work but not showing on my smartphone. I reassure myself... to double-check... so I copied the same mp3 files to my USB flash drive than played in my car through a USB. It played fine without an issue and the album image showing on my stereo deck.

Solutions to Concussions: I just use Mp3tag to do my things. Remove all embedded image from my mp3 files and then saved all to ID3v2.4 UTF-8. Instead of trying to use Mp3tag, I'm using iTunes to embedded my album art work. It turn out to be fine no problem showing album image on my smartphone.

I'm not sure if this is something that I did or in my Mp3tag settings. Please help.



I am not sure if you got it right:
UTF-16 is written for the V2.3 standard.
UTF-8 is written for the V2.4 standard.
There is not UTF-16 for V2.4.

And as these 2 standards represent a different approach to writing the tags. The WIndows Explorer, e.g., does not read V2.4 tags alltogether.
So it could be that your mobile cannot cope with V2.4 tags...
I would return to V2.3 tags.

There is also a thread in the FAQs on strange displays: /t/2785/1

The solution to use iTunes for tagging is weird as iTunes very often does not really tag files but writes data only into its database. I wouldn't do it.

Edit: to make sure that your files are ok you should use mp3val and mp3diags to check their integrity - to find out that the hicups do have their origin in some corruption.

You are obsoletely right about there is not UTF-16 for V2.4. My bad, I have copied from ID3v2.4 UTF-8 and replaced with UTF-16. Secondly forgot to corrected V2.4 to V2.3

Let make this long story short. In this case, my Windows 7 and smartphone are both capable can cope with V2.4 tags in which is ID3v2.4 UTF-8.

As you mentioned above, I have returned to V2.3 tags. When done edited tags with V2.3 than I copied the mp3 files to the phone. On my mobile phone... 8 out of 10 files displays correctly in Vietnamese language characters and the other 2 displays as squares and weird characters. Problem still persists and I still don't know what to do.

If I go with V2.4 tags... no problems with Vietnamese language characters, but no artwork image showing up.

If I go with V2.3 tags... I have my artwork image showing, but problem with language characters.

I have tried ID3v2.3 ISO-8859-1. but no luck there... Windows Explore and mobile phone cannot cope with v2.3 ISO-8859-1. Both displays as squares and weird characters.

The only thing that I could do for now is that I go with V2.4 tags without artwork embedded than to use iTunes to add artwork and that is the only thing to get both language characters and artwork to do the job right 'in the way'. After using iTunes to add artwork, I go back open Mp3tag program load my previous folder that I have working on. All artwork embedded in each mp3 files. Weird but this is not the correct way of doing it.

I'm not familiar with mp3val and mp3diags. Let me spending sometime reading online about it and how to do so, thanks ohrenkino

Any advice the above issues

Best regards,


If you have some strange files, then you should check them with mp3diags first - it could be that mp3diags reports a sub-optimal character encoding for some fields. And Mp3diags can repair this fault.

I still do not think that you can see any tag data in W7 Explorer, if you have V2.4 tags ... So which program did you use to check?

ohrenkino, thank you for taking the time to assist me here.

I have downloaded mp3val and mp3diags. Both programs are just beyond my capability to learn because I'm lost and confused about tags.

I went through so much trouble and no success. I took my CD out again "legit, paid, purchased CD". Using Easy CD-DA Extractor program to audio CD ripper with output setting UTF-8. Brand new mp3 files and still having problems.

I have been using Mp3tag for about 18 months Off/On. Before my tread - posted here, I use Mp3tag as always enter my tags, add covers than saved all my files in Mp3tag's default settings.

It works fine before Mp3tag writes ID3v2 tags in Unicode format (UTF-16) by default now. Now I have learned between the two versions v2.4 and v2.3 and what it does... thank you to you for that.

As far choose target characters go... is just beyond my control. Save as Unicode 8 v2.4 or Unicode 16 v2.3 and the outcome is dependent variable responds.

Here is why, if I saved my files to v2.4, my artwork don't even show on my mobile phone, but if I saved to v2.3 my artwork shows, but my album end up splitting in pieces because due to weird characters.

For the time being, I have returned to V2.3 tags and saved all files and tags to that version. Language displays with weird characters. My single album end up split in 3,4 or 5 in the music player. After all that I don't really mind.

Now, in Google Play Store I have downloaded an app "ID3Fixer". From my mobile phone run that app than search for each split album that I have some strange files "weird characters" than I choose target characters to UTF-8, UTF-16 or Windows-1258 (Vietnamese)... It has a quick preview window to see which characters set is right for you. While in here I have an options to fix tags in music files permanently or fix Android database only, does not affect the music files. I have tried them both and it works perfectly. All weird characters now fixed.

ohrenkino, I'm just curious. What do you know about saving tags to v2.4 and no artwork image shows on your phone?

Best regards,


Please see attached image

I doubt that the smartphone knows how to cope with 2.4 tags. Probably it relies on the V1 tags (which you probably store also - you may check that in Tools>Options>Mpeg) and V1 tags do not have embedded covers.
If your albums are split up then I think that this is not due to "weird characters" but that you have not filled the ALBUMARTIST field - because if the ALBUM field has the same data then it should be sorted properly. But with varying artists you need the ALBUMARTIST field to get the grouping.

In general should the UTF standard be sufficient to display any character in the world. It gobbles up 2 bytes for each character, though.
If you see the squares then it is the smartphone that cannot cope with UTF characters ... but it interprets the 2-byte-definition as the old ANSI/ASCII-one byte set of characters. THis is old style and not up to date any more. See if you can get an update or a different player.
(This is what I assume from your descriptions - I could be wrong)

You now have to decide which of your tagging platforms is the pacemaker.

Something else: V2.4 is a standard but not a widely supported one. If you want to stay compatible, I would (currently) use V1 and V2.3 tags.

Hi ohrenkino,

"Your Quote" If you want to stay compatible, I would (currently) use V1 and V2.3 tags.

My mind is fried... Would you please show me how to use V1 and V2.3 tags? Thanks


In Mp3tag go to Tools>Options>Tags>Mpeg
There you find the options to read, write and delete.
Check all type for read and delete
For write check only V1 and V2 and for V2 set the second option: ID3V2.3 UTF-16
That should do it. Every time you modify the tags in a file, only these 2 standards are written: V1 and V2(.3) (and no APE and not V2.4).

Hi ohrenkino,

Thank you for your reply! I have been messing around with that too and I still have no luck.

3 days ago from today! I downgrade the Android firmware Galaxy S4 back to stock from v5.02 to v4.1.2.

Software Update! I Check new updates in the phone settings. It took me 3 days and 4 updates to get to Android v5.01.

Android v4.1.2, v4.4.2, v4.4.4 I have no problems with ID3v2.3. Android v.5.0.1 it seemed like cannot cope with V2.3 tags... due to "weird characters" like letters, fonts, characters and symbols.

Sorry ohrenkino and here I go again. ID3v2.4 supported letters, fonts, characters and symbols but no artwork showing up. Please see attached pic.

To solve this issue... probably I have to go back to Android v4.4.4. Any suggestion? thank you in advance.

If you see weir characters, you might want to have a look at this thread:

about problems with unicode characters.

Then, if you do not see pictures, it could be that they are too large. Some phones do not like pictures bigger than 200*200 ...
You would have to adapt the size of the exported pictures with an external program and then re-import the resized ones.

This setting is not possible within Mp3tag.
Possible settings are ID3v2.3 UTF-16 or ID3v2.4 UTF-8.

Which tag-type is supported by iTunes ... ID3v2.3 UTF-16 or ID3v2.4 UTF-8?

It is rather not expectable, that popular devices support reading of ID3v2.4 tag-type, ...
therefore I do not believe, that your Android can understand the ID3v2.4 tag-type.

You should setup your Mp3tag to read, write, delete ID3v2.3 tag-type.
Additionally remove possible existing APE tag-type from the media file.
Note: The APE tag may hold one or more pictures, which you may save to disk, before removing the APE tag.
Note: Mp3tag treats the APE tag with higher priority than the ID3v2.x tag-type.

After removing the APE tag from the media file, you should setup your Mp3tag to never use the APE tag again, so set all APE related checkboxes to "off" in the dialog "Mp3tag Options/Tags/Mpeg".


I just uninstall and reinstall Mp2tag v2.71. Also, make sure my newly installed programs are set to default settings.

I tested on iPhone 5S, 6 and they both supported ID3v2.3 tags. It's the Android firmware v.5.0.1 and v.5.0.2 that cause me all the headaches.

ohrenkino, I have tried to enable the option ID3v2.3 ISO-8859-1 and that didn't help either. My pictures were 300x300 and now have resized down to 200x200 still no luck.

DetlevD, iTunes supported both ID3v2.3 UTF-16 and ID3v2.4 UTF-8. As I was saying... since I updated Android firmware Galaxy S4 to v5.02, this is where I am having problem with ID3v2.3 tags in Unicode format (UTF-16) by default now which I think Android firmware at fault.

For now, I have to force myself to use ID3v2.4 UTF-8 because it shows correct characters in Unicode format. Problem with that is that no artwork/picture showing up. To resolve this issue please see below it's a two step process.

Step 1: Set Mp3tag Tools>Options>Tags>Mpeg to ID3v2.4 UTF-8, than remove cover/picture... after that, just save the tags again by clicking Save without pictures.
Stip 2: Open iTunes, go to music library, right click on the album then select Get Info.. after that go to Artwork Tab then add Artwork picture.

Using iTunes to add artwork for tagging is weird because I don't think iTunes can write any tags but capable adding artwork picture.

Believe me guys, I'm certainly not saying that Mp3tags is bad or anything like that. I was lost and confused and I must say thank you to the Mp3tag software developer is the creative minds behind computer programs.

It would be interesting to see if the covers not only appear in iTunes but also in the tags and consequently in mp3tag ...
I mean: what should iTunes do better than MP3tag?

Just to be sure that the files are up to standard: could you check them with mp3val and/or mp3diags (both freeware, currently) to see that not some freak misconfiguration causes all this trouble?

Please bare with me... I think I just solve my own problems.

The last 4 days... I have downgrade the Android firmware Galaxy S4 back to stock from firmware v5.02 to v4.1.2 and than firmware updates back to Lollipop, Android v5.0.1.

Now I can confirm ID3v2.4 UTF-8 and IDv2.3 UTF-16 are not working out for me on the newest Samsung Galaxy firmware (Lollipop, Android v5.0.1), because my language has special characters.

I know it worked just fine on my previous Android firmware v4.1.2, v4.4.2, v4.4.4 with ID3v2.3 tags... Now I am on Android firmware 5.0.1 and it cannot cope with it V2.3 tags... all I see the tags are not showing up properly in the Android stock music player.

This is really frustrating, it took me two months and just now I finally realized this could work. Please read more below.

Who would have said iTunes can write its own tags? See pic. and please correct me if I'm wrong.

1st I use Mp3tag to remove all tags. 2nd I use iTunes to edit tags and add artwork picture... Once done after that I use Mp3tag again to verify iTunes tags info and what I see? I see tag was save to ID3v2.2 (ID3v2.2).

In order characters worked correctly, my tags must be save to ID3v2.2 (ID3v2.2). Perhaps, maybe... we could that options ID3v2.2 in Mp3tag Tools>Options>Tags>Mpeg along with ID3v2.4 UTF-8 and IDv2.3 UTF-16?

ID3v2.2 compatibility mode in the MP3tag options makes it all work for languages that have special characters. ID3v2.3 ISO-8859-1 don't work for me here. Actually v2.2 is supported just not v2.4 and v2.3. I am not exactly sure what it changes, but it seems to fix it. So if that's the case using v2.2 would be the solution.

For now you have the same output on both sides, on Android and on Mp3tag, when using the tag-type ID3v2.2, which has been written by the iTunes Software.

Note: In ID3v2.2 and ID3v2.3 there are textual frames marked with an encoding byte ...
$01 – UCS-2 (UTF-16 encoded Unicode with BOM).

It could be of interest to see what happens, when the tag-type will be changed to ID3v2.3 UTF-16.
Use a copy of the media file, which has the tag-type ID3v2.2, and load the copied file into Mp3tag.
Setup Mp3tag to read/write ID3v2.3 UTF-16 and re-write the file.
Check the text in the tag-fields in Mp3tag, what has been changed?
Check the text in the tag-fields in Android, what has been changed?

See also ...