iTunes 'Grouping' tag

I'm struggling to get the iTunes 'Grouping' tag (and a couple of other tags) to display in MP3Tag - any thoughts please? I've attached a screenshot from MP3Tag:

and a test tag exported from MediaInfo: Gomez test (1.0 KB)
FYI the file is an ALAC/m4a
Thanks for any pointers

see here:

and the help for supported fields:

Thanks (I think). What about the older (and better IMHO) 10.7.021 version of iTunes that a lot of people seem to prefer? Anyway, this 'Grouping' tag is currently visible in the file/tag using MediaInfo (see previopsuly attached zip), so why am I struggling to find it in MP3Tag? It shouldn't be related to the version of iTunes.
BTW I've been though 'help' Tag Field Mappings – Mp3tag Documentation and I'm now considering going through every tag and adding it just to prove it's not there :frowning:

Another way could be to fill the grouping tag in iTunes, make sure that the modifcation is saved to the file and then have a look at the file with MP3tag and the extended tags dialogue (Alt-T). There you should see the field that causes the grouping.

Here is the note from the change log (

[2017-02-17] REL: VERSION 2.81 (for Windows 10/8.1/8/7/2008/Vista/2003/XP SP3)

[2017-02-06] NEW: added support for iTunes-specific ID3v2 grouping tag field GRP1 as GROUPING.

(Trying to put this as politely as I can...) I guess you didn't read my first or second post?! I've done exactly just that (see the zipped up demo tag file) :wink:
BTW I seem to be on v2.99a of MP3Tag
I'm not missing something am I? Should I enter %grouping% in both field and value fields or %GRP1% in both - though neither works.
I tried it the other way around ie wrote the grouping tag in MP3Tag and see what change it makes to the file - here's the output for both %grouping% and %GRP1%

MP3tag hasn't written to the 'Grouping' tag but the 'grouping' tag in this case (I tried to write 'test grouping' in both attempts) - I'm going to try to see what happens when I capitalize this...

As the already linked list of supported tag field names shows:
GROUPING is the name of the field.
If you intend to define a column, enter %grouping% for VALUE and FIELD.
%GRP1% would lead to a user-defined field called GRP1 which is not the identical to the ID3 standard field.

Please see also the description for CONTENTGROUP for MP4 files.

Thanks (I see what you mean about the GRP1)
If I capitalize the field and value entries as %Grouping%, and then enter 'retest grouping' in MP3Tag then the output it writes when it saves the tag in MediaInfo is this:

so clearly there is a capitalizing issue and that the use of %Grouping% in both field and value is correct but why doesn't MP3Tag read the original 'Studio' that was present beforehand? and how does it know to append it?
Oddly the hex show this

and the 'Studio' entry is elsewhere in the file:
I'll look at CONTENTGROUP shortly

(Sorry to reply to my own post)
I think you've got it - ContentGroup writes to the 'correct' tag like so (with 'Studiov2' as the amendment)

I guess the other method is creating a duplicate tag that MediaInfo was interpreting as the same (or appended) tag.
Thanks for the help again