Mp3tag 3.18 opens behind all other windows

I don't know if this is an Mp3tag issue, or something wrong in my system, but when I open Version 3.18 (including the betas) the main window opens behind all other open windows ("Z" in Z order). I'm running the latest Windows 11 version.

EDIT: This only happens when launching from the context menu.

Are you using the context menu extension added by the installation program or anything manually added or registered?

As far as I know, there’s nothing installed but the context menu from Mp3tag. I can launch other programs from the menu that behave normally.

Jim K.

I've tried to reproduce this on an updated Windows 11 system and Mp3tag opens as foreground window, also when started via the Explorer context menu.

Can you please make sure that you have all updates installed. If this still doesn't solve the issue, try uninstalling Mp3tag, reboot, then re-install Mp3tag.

Thanks, Florian. I'll do a complete uninstall (including the registry settings) and reinstall to see if that helps.

Hi Florian,

The uninstall/reinstall seems to have worked. I'll let you know if the problem returns.

Jim K.

1 Like

It only worked briefly, then reverted to the previous behavior.

Here's the reply I received from Christian Ghisler, the author of Total Commander:

Sorry, I don't know what else you could do, except for contacting the author of Mp3tag. Total Commander launches all programs with option SW_SHOWNORMAL. But the context menu item is a shell extension created by mp3tag itself, so maybe it's calling the program with the wrong parameter SW_SHOWNA (show, but do not activate).

I'm using SW_SHOW and SW_SHOWNORMAL there, so it should get activated based on the provided command.

Someone here on the message board posted instructions for implementing an Mp3tag button on the vertical button bar in TC. It works great, and the program opens as it should. I'm fine using that instead of the context menu, so I'm just going to chalk up the context menu thing to some peculiarity on my machine. Thanks for your help, Florian.

Could you please let us know, if you need this parameters in TC?

Not sure if needed, but I used


1 Like

Hi Florian,

I just installed the new version of Mp3tag (after doing a deep uninstall of 3.18), and the context menu is now working correctly. Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.