MP3Tag Won't connect to Discogs

Can you please revoke the authorization on https://www.discogs.com/settings/applications and try again.

The problem magically went away a couple of days later. If it acts up again, I will try that. For now, everything is working so I won't mess with it.

Since 2014-08-20 I have the same problem. I followed the advice to revoke mentioned above but no success!!
The only thing I have found is that Discogs is having the following message on their site:
We're currently investigating network connectivity issues and are working to have things back to normal soon; please check the forum for updates.

Also all my Discogs scripts (like the "Pone") are not working.

Other databases are working OK

I'm having the same problem. It gives me this

To me it does not look like the same problem.
Did you follow the instructions in the release notes: Mp3tag v2.62 released

Checked Discogs again at 2014-08-21 20:18 hr: message about "network connectivity issues etc."
was removed and Mp3tag and associated scripts are working again, at least in my case.
To be sure that I had a clean installation I removed every trace of Mp3tag (register, roaming etc.)
did a clean install and regenerated all my scripts.
However, I think the problem was at Discogs and not in Mp3tag...

So; up to the next hickup of Discogs... :angry:

edits: typo's

I have not been able to connect for at least the last day, receiving error:

I tried revoking the authorization several times & it doesn't change.
What is going on???

Do you get a message box if you try
Help>Check for new version
?
If not then you have to check your local network environment, esp. the firewall.

Yes & disabling firewall does not change the result, to note this was working a few days ago on 2 different PCs with different network protection software & it worked fine so I don't think this is the issue.

Fact is: if you do not get a message box saying something like you have the latest version or there is a newer one then MP3tag (and all web scripts) do not have web access.

I do, this isn't an issue.

Looks like the default "discogs" script does not work any more.

You have to wait for a new version or you can try one of these:
/t/9226/1
/t/1992/1

Why did Discogs change this after many years?

Is there a control issue here?

f**cking discogs REMOVED XML output completely !!!! :angry: :angry:

so you have to completely re-write your well tested and used scripts for years to their new JSON format.. what a wasteless c**nts..

i'm sorry for the rant but they are just pissing off not the first time..

I think they now want email addresses so they can send you spam and try to make money off you. If they ever start requiring credit card numbers, then I hope they die a withering death and fade off into nonexistence.

In the meantime they can have my bogus spam account because that's what it's set up for. Or I'll try to use the other tagging databases that Florian has offered to us to get around it.

got a reply from support saying url like:

http://api.discogs.com/releases/?f=xml should work without any problems..

but it outputs json instead of XML...

I've rewritten the official Discogs Tag Source to be used with the Discogs API.

The rewrite was necessary, because the Discogs API has been changed to provide output in JSON format instead of XML (see this post in the Discogs API Announcement Forum for details).

Enjoy your Discogs tagging with the current Development Build and please let me know of any issues you encounter :slight_smile:

Kind regards
Florian

Wooo thanks boss, It's like Christmas! :santa:

I updated to v2.68 then revoked and I am getting:

Failed to Authenticate using OAuth (1).

Any ideas?

You could rename the mp3tag.cfg file to re-invoke the registration process.