No explorer context menu integration

Installed version 2.5.2 in Windows 7 Home Premium 64bit

There is no integration in Explorer when I select a folder or folders and try to open with MP3TAG, no MP3TAG is in the context menu.

Any suggestions?

Did you by any chance install in "portable" mode by mistake (or actually "install" a portable version)?

I believe having a mp3tag.cfg in the same folder as the EXE would definitively imply a "yes" answer.

Otherwise I'd guess it's an issue with the 64-bit 'ness.

No I remember that option and did not choose it, no cfg file either, oh well I will have to hack the registry to add it, would be nice if this was fixed for 64bit installations.


Here is the registry code to add mp3tag to the context menu

Windows Registry Editor Version 5.00


@="C:\\Program Files (x86)\\Mp3tag\\Mp3tag.exe "%1""

To get context menu integration you must select it when running the installer.

Ah, you are correct, I must have missed that option, thanks!

One more thing, evidently Windows 7 has a folder selection limit of 15, if you select more than 15 folders in explorer most of the context menu items disappear, including MP3TAG

But there is a fix

The official context menu integration that comes with the installer does not have this limit.

Thanks, I will re-install it!

I just tested it and did not see any such limit. I selected about 2000 folders and the MP3Tag item was still properly listed in the context menu. I'm using Windows 7 64bit. I'm using Directory Opus, not Explorer, so if that limit exists, it's in Explorer, not Windows 7 itself.

I know this post is quite old, but just tried the above to add context menu for portable edition but just threw up couple of errors (when I tried with/without the "@=" bit at the start. Aside from just adding to SendTo menu, any suggestions how to enable this with portable version?


The mentioned reg-file still works. I just tested it in a virtual machine with W10 64 Bit, where I have MP3Tag 2.81b installed with the protable alternative of the installer.
Did you change the reg-example to your correct path to mp3tag.exe?

I did. I'll feedback back with exactly what I put in there and error messages I got. Meanwhile, presume you need the'@' bit at the start?


Did you try to enter this manually to your registry or did you copy the text to a reg-file and change your registry with a double-click on the reg-file?

The text you quoted is an export-reg-file of the registry. Just copy & paste this text in a plain editor, correct the path to mp3tag.exe, and save the text to a file with the extension "reg". Then double-click on this file and confirm "that you know what you are doing".

If you want to add this entry manually within regedit you have to create the tree manually and the correct entry within command would be:

C:\yourprogrampath\Mp3tag.exe "%1"

I don't know if it makes any difference but I created the "portable installation" with Mp3Tags installer and not manually. Since version 2.81 Mp3Tag gives a choice to install it portable. Before this you had to create your portable version manually without the help of the installer.
Your profile shows you are still using "Mp3tag Version: 2.35", just a not actualized entry?

24 posts were split to a new topic: No Explorer context menu on Windows 11