Not showing the Year, Comment, Copyright and Web address details.

I have Nokia E7 phone with Symbian Belle (refresh) operating system. When I try to see my music details, the device cann't showing the Year, Comment, Copyright and Web address details.
I think actually it is not the device problem. Becouse, other music which one not converted through MP3Tag is showing properly.

Is there any solution for it?

What audio format? If it's mp3 try changing the tag encoding:

Thanks dano for your reply.
I followed your suggestion. But not worked. (My music collection in 'MP3' format only)
Is there any other suggestion?

Does MP3tag still show the right values?
In the dialogue that Dano mentioned you could also check if you read or write APE tags.
And then, if these tag versions are present in your files by applying a filter
%_tag% HAS APE
If you read or write APE tags then untick these options and leave over only the delete option.
Then use the special tag function that you find in the contextmenu of the files list to cut&paste the tags.
Perhaps the phone really only reads genuine V2.3 tags

ah, yes - and if all this is fine, you could check your files with mp3val.

Hi ohrenkino

In MP3Tag all details of my albums are showing properly.
I checked Read and Write of APE tags and applied the above filter. In this test also it passed.
In MP3Val test also my albums passed.

I am not understanding why not showing the details of Year, Comment, Copyright and Web address only!

What can I do now????? :smiley:

It is very hard to tell from the distance what might go wrong.
So, the only way is: compare a file that works with one that does not.
If they are both the same, then you have to consult the app's support.

Please run this export script against the file and show us the report output.

1: $filename($getEnv('USERPROFILE')'\Desktop\Mp3tag.Report.tagdump.'$replace(%_datetime%,' ','.','-',)'.txt',UTF-8)$loop(%_path%)'^'

2: $regexp($regexp($list(,': ''',''$char(13)''$char(10)),'\r\n','U+000DU+000A'),'\r\n','\r\n')''
3: $regexp($regexp($listtec(,': ''',''$char(13)''$char(10)),'\r\n','U+000DU+000A'),'\r\n','\r\n')''
4: 'MP3TAGAPP: '''$getEnv('MP3TAGAPP')
6: '$'
7: $loopend()

20120601.Export.tag.dump.mte (592 Bytes)


20120601.Export.tag.dump.mte (592 Bytes)

Hi DetlevD,

Sorry for this question.... exactly I don't know how to run the given script. Please tell me how to run it in my windows 7, MP3Tag v2.54, system... or give me 'script run' method link.

I tried to run the script through
Actions>Actions (Quick)>export>New......

I don't know is it right or not. If this one is right... then I am attached report file here.

Mp3tag.Report.tagdump.1132013.124456.AM.txt (10.4 KB)

Sure a way to get the wanted result.
Thank you.

Now please give us a report from one file which is 'showing properly'.


Here attached the 'showing proper' album's report

Mp3tag.Report.tagdump.1132013.20126.AM.txt (1.82 KB)

I would say, it is an encoding problem. these are 'UTF-16', the other ones were ISO-8859-1:
So it's back to dano's post in #2

My all problem albums are with default ('UTF-16') encoding only. After dano's' suggestion I changed to above encoding. 'UTF-16' and ISO-8859-1 also not working. That's why this thread flowing this much.

Thank you.
I have tried to detect differences between the reports and there are few points, which need attention. (17.2 KB)
See attached PDF file. I have marked the lines with three question marks "???".

??? DISCNUMBER: 'Giri'
(excerpt from ...)
The 'Part of a set' frame is a numeric string that describes which part of a set the audio came from. This frame is used if the source described in the "TALB" frame is divided into several mediums, e.g. a double CD. The value may be extended with a "/" character and a numeric string containing the total number of parts in the set. E.g. "1/2".

??? file_mod_datetime_raw: '1358010695'
It is somewhat remarkable that six files in series have the same raw datetime value, but obviously it can happen.

??? id3v2_character_encoding: 'ISO-8859-1'
??? id3v2_character_encoding: 'UTF-16'
I would recommend to use encoding 'UTF-16' together with the Nokia E7 phone, from which someone can expect, that it supports the standard ID3v2.3 UTF-16.
There seems to be a lack of documentation regarding such properties.

??? total: ''
??? total_files: '1'
(6 files in report)
??? total: '6'
total_files: '1'
(1 file in report)
I have no clue how to explain these status messages.

??? volume: ''
??? volume: ''
I have no clue why Mp3tag does not show the volume info.

At the tag-data level I can not explain exactly or suspect what the reason may be for the problems on your side.
The hex data from a suspicious file should be examined.

To be able to read data from a tag field, the field must be applied and filled with data.

My last idea for your problem is ...
Perhaps there are multiple stacked tags that cover each other and interfere.
For testing (use a file copy), you can cut out resp. remove [Ctrl]+[X] the currently visible ID3 Tag (check and set Mp3tag Options), and then examine, whether there has become another ID3 Tag visible or not.

DD.20130113.1109.CET (17.2 KB)

Just an amendment: Mp3diags detects such stacked tags and reports them.
It would be sufficient to diagnose a file with problems.

Hai DetlevD,

I stunned of your through study on this problem. Unbelievable way of trials!!

I am amateur user of MP3Tag. Just utilising it for remove garbage tags and listen clean music.
In this case, I not expected this much research. Just wanted simply remove my problem through this forum.

Now I don't know what I have to do next. If you want ... I can upload audio files for further study. If not that much useful then I will continue with this problem.

Any how thank you very much!

Although I am not DetlevD and before you upload anything:
Could you check one of the problematic files with the freeware Mp3diags?

Hai ohrenkino

Thanx for suggestion.

I am not getting Mp3diag software process. It is little bit hard to learn soft.

Click the cog-wheel from the toolbar and select the folder in which the files to be checked are.
Let Mp3diags scan the files.
Press the yellow filter button and check which problems can be filtered.
If that dialogue is empty, everything is fine with the files and you have to check why your phone does not behave.
If there are messages then try to repair the files - if the messages suggest broken integrities.

I just followed your suggestions. MP3Diag showing these problems,

  1. Low quality MPEG audio stream. (What is considered "low quality" can be changed in the configuration dialog, under "Quality thresholds".)
  2. No normalization undo information found. The song is probably not normalized by MP3Gain or a similar program. As a result, it may sound too loud or too quiet when compared to songs from other albums.

I think these two points are not representing our case.