Opening Cuesheets broken?

Hi,

it's been a while since I opened CUE sheets in Mp3Tag, but last time I did (around version 3.03) it worked as expected. That means when opening a CUE sheet, Mp3Tag would display the contained list of tracks and I was able to copy the tags and paste them on the corresponding files.

I tried this again with version 3.07 (and also 3.07b dev build) and when I open a CUE sheet now, it simply shows a single entry with the file name of the CUE sheet.

I checked the release announcements for version 3.02 - 3.07 to see if CUE sheets were mentioned, and didn't find anything. That makes me assume it might be a bug.

So as simple step-by-step summary:

  1. Select File -> Open playlist/cuesheet
  2. Open any cuesheet
    Expectation: The contained track list in the CUE sheet is displayed
    Reality: The CUE sheet itself is shown as a single entry

Best Regards,
icerain

I've tried to reproduce the issue and it works without problems here. It might be something specific to the cuesheets you're trying to load.

Can you check if the files of the referenced filenames exist and if you can't spot anything obvious, provide the cuesheet and the corresponding files for analyzing purposes?

Thank you for your reply!
To be honest, I never assumed the referenced files existing would be a requirement for the Cue sheet to be shown as expected.
I was able to pinpoint when the change in behavior happened: Mp3tag v3.03d works as expected, v3.03e or newer does not.

Maybe the older version displaying the Cue sheet's contents even if the referenced file does not exist was a bug that was fixed?
Anyways, I attached two screenshots (v3.03d vs. v3.03e) as well as the Cue sheet I used for them (zipped)



Ulla van Daelen - Harfe solo - Mandala.cue.zip (897 Bytes)
.

I also need to revise my error description: The newer versions show only the first track listed in the Cue sheet.

Best Regards,
icerain

Many thanks for the detailed and helpful analysis of the issue! I was able to reproduce it locally and will fix it to the next release.

1 Like

I've fixed it with Mp3tag v3.08. Thanks again for reporting!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.