Problem with the width of tag panel on startup

I can't reproduce it and also after a thorough code review, I can't see what's causing the issue.

Which version of Windows are you using and what are your DPI settings?

It's Windows 10 Version 1809, using three screens - two wih 2560x1440, one with 1680x1050px. I 've just tested it. It happens on the big screens only. When started on a 2560x1440px screen this problem occurs. no problem at 1680x1050.

I've tried with my 2880x1800 (also at 2560x1600) with no success at reproducing the issue.

I'll have to keep that open for now.

Maybe as a follow-up question: are you running any third-party software that might interfere with the resolution, DPI or reported window sizes?

Another user who reported the same issue via email mentioned, that the problem solved itself after some Windows updates.

Just checke my system. It's up-to-date. Unfortunately still the same problem

I have just noticed:

  • There is no problem when its opend in full screen mode
  • It happens only when its not opened in full screen mode (as I do)

Just guessing, but this is probably due to no scroll bar appearing if you run it in full screen mode.

I have a scroll bar when opened full screen, and the text field drop-down icons appear. Otherwise same symtoms as above.

A wild guess, but in the GUI design, would it make a difference if the text fields were anchored to the right side of the panel? Wouldn't think it'd make a difference, but something wierd is going on.

Mp3tag v3.03
Win10 20H2 Build 19041.685
Same symptoms on both displays :
Asuslap Display : 1920x1080, 175% Scale
HP Display 1920x1080, 175% Scale

Just a notice. I still have this problem. (v3.04a)

This should now be fixed with Mp3tag v3.06b. Thanks @CarlosLosTopografos for help in debugging this issue!

Hello, the problem is still existing. I use MP3Tag since years but I have only seen it with my last laptop, a DELL running W10 Pro 20H2. MP3Tag is in its last revision, v3.06a. However I am not sure environment is the problem, since it's easy to reproduce : if the column width is high enough to get the elevator slide it appears when MP3Tag is launched, otherwise not. In other words if the column is narrow enough to not hide partially the cover screen and MP3Tag is closed and then reopened no problem. With my other computer I have a big screen and probably never use the application's window the same way.

If you look closely

then the latest version is 3.06b. So it would be nice if you could test it also with that version.

Hello, unfortunately it's even worse : now the problem is also present when the column is narrow.

So maybe it's not so simple that I though... Thanks for support !

I've compiled a test build with some additional logging. Can you prepare the Mp3tag window that it shows the issue, close Mp3tag and install this test version from

https://download.mp3tag.de/support/C25106B4-FD26-4ED9-B407-1501D5990279-3623/mp3tagv306b3setup.exe

Then open Mp3tag (it should show v3.06b3 in the title), don't resize anything and then close right away.

Then I'd need the Mp3tagError.log from %APPDATA%\Mp3tag (or the program folder, if you're using a portable version).

Thank you!

Please try v3.06b3 from the link above and let me know if this fixes the issue.

Still working here

1 Like

The 2nd attempt in fixing this bug: Mp3tag v3.08c should fix the issue for everyone.

Thanks @v4c, @Psychoticsixx and @CarlosLosTopografos for your help in testing all the intermediate versions :sweat_smile:

Sorry I was in holidays... Seems fixed now, I have tried with my portable and three other machines (two W7 and one other W10), without problems. Thanks !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.