Renaming Recovered FLAC Files In A Large Batch From Hard Disk Crash On Mac OS X 10.6.8

Hi thanks for the feedback. I will get rid of the spaces.

I didn't put the "?" in. It was there by virtue of the path given when I dragged the folder to the mp3tag interface.

Please note I had to do that for mp3tag to see the files. I could not locate the external USB drive by browsing my MacBook.

How do I get rid of the "?" ?

Thanks

Perhaps this thread helps you to find the drive
https://forums.mp3tag.de/lofiversion/index.php?t20435.html

I followed the path in the thread you referenced.

I can locate my external hard drive in Volumes but when I load it onto the mp3tag interface, the path still has the "?" there as in:

"\\?\unix\Volumes\Old Files Recovered\3649030 (FLAC Deleted)\01\0A2C0718.FLAC"

Any help appreciated please.

Thanks

I am also puzzled by the double backslash. at the beginning.
This is the indication that the next string part is the name of a network device.
I am not sure if MP3tag supports this notation - to be on the safe side, you should assign a drive letter to that target.
Also, I find it a strange thing that your Windows emulator uses illegal characters in the filename. You should investigate how to get rid of those before you attempt any further retagging.

The windows emulator was downloaded together in the package with mp3tag.

How do I assign a drive letter to the target drive?

How do I get rid of the illegal characters?

Any help appreciated.

Please see /t/9889/1 on MP3tag on Mac OS.

If the app-way is not sufficient as it causes problems with the external drive you have to look for a different way: either copy the files onto the internal volume or use a different emulator.

I can tell you only the conventions as expected by a native windows program. You have to make sure that these standards are met on your system. How to do that? I cannot look over your shoulder and cannot see what options you have.

I don't know how to assign a letter to a network drive in a Mac. In windows, one goes to START > THIS PC > Computer > Map Network Drive, and assigns a letter.

Thanks for your feedback. I am using the wine emulator from the OS X package so I guess that is a problem. I do not have enough disk space on my internal volume as the files total about 460 Gb. I do not know enough to use a different emulator.

So I guess I will just resort to renaming the files manually. So much for mp3tag.

Thanks

Thanks garym

I don;t think you can assign a drive letter on Mac drives. They just have the name. In my case, the drive is called:

Old Files Recovered

Under the path in the mp3tag interface, when I browse, the internal volume shows up as "/"

The external drives all show up under the subdirectory "Volumes". This particular drive shows up in a further subdirectory "Old Files Recovered"

The problem is the path shows up as

"\\?\unix\Volumes\Old Files Recovered\3649030 (FLAC Deleted)\01\0A2C0718.FLAC"

So it is having a problem with the internal volume itself I think because the "?" is added even before the "Volumes" subdirectory. Once again, this is just my guess with my limited knowledge.

I just tried using the iTunes subdirectory on the internal volume and even so, it is showing up as:

"\\?\unix\Music_1\iTunes\iTunesMusic"

So I guess mp3tag will not work even on an internal volume.

can you copy this complete path with all the files to an external USB drive, and at the same time give that path (on the USB drive) a more accessible name that mp3tag might be able to use?

I can just rename that entire drive not a problem but what would be a more accessible name that mp3tag can use?

Say I renamed it "z: Old Files". the path will still be:

"\\?\unix\z:\Old Files"

It doesn;t get rid of the "?" which comes into play before any of the volumes internal or external enter the picture.

I'm talking about copy and paste files not renamiing current folder. Maybe I'm misunderstanding (and I'm thinking only about windows as I don't use a Mac), but if I had files on my harddrive that were located here:

\\?\unix\Volumes\Old Files Recovered\

I would navigate to the "old files recovered" folder, select all the files and subdirectories within that folder, then COPY.

Then I'd have a USB drive connected to my computer. On that USB drive I'd have a folder setup with the name:

OLDFILESCOPY

Then I'd simply paste those files I copied into this new parent folder. Is that not possible.

Hi

I have done that already. Same problem.

All drives internal and external, USB or Firewire will appear under the "Volumes" directory. I have another Firewire drive called My Book attached to the same Mac, where I copied the files to. It appears as:

\\?\unix\Volumes\My Book\

The problem is not the file naming I believe, it is just that mp3tag will append any Mac OS X hard disk with "\\?\unix" before the disk or directory name. From then, you cannot rename the files because the "?" is illegal.

That I think is the problem and cannot think of a solution.

If it were me, my next step would be to copy all the files to a USB drive then find a friend with a windows machine, install mp3tag on it, then rename all the files using that windows machine.

You might also try "puddletag"

http://vortexbox.org/forum/vortexbox/gener...ddletag-on-os-x

http://docs.puddletag.net/download.html

I am trying to install puddletag.

I followed the instructions byt get the following error

Last login: Wed Jun 1 13:28:47 on console
Auns-MacBook:~ aun$ /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/.../install)"
==> This script will install:
/usr/local/bin/brew
/usr/local/Library/...
/usr/local/share/doc/homebrew
/usr/local/share/man/man1/brew.1
/usr/local/share/zsh/site-functions/_brew
/usr/local/etc/bash_completion.d/brew
==> The following directories will be made group writable:
/usr/local/.
/usr/local/bin
/usr/local/include
/usr/local/lib
/usr/local/lib/pkgconfig
/usr/local/share
==> The following directories will have their owner set to aun:
/usr/local/.
/usr/local/bin
/usr/local/include
/usr/local/lib
/usr/local/lib/pkgconfig
/usr/local/share
==> The following directories will have their group set to admin:
/usr/local/.
/usr/local/bin
/usr/local/include
/usr/local/lib
/usr/local/lib/pkgconfig
/usr/local/share

Press RETURN to continue or any other key to abort
==> /usr/bin/sudo /bin/chmod g+rwx /usr/local/. /usr/local/bin /usr/local/include /usr/local/lib /usr/local/lib/pkgconfig /usr/local/share
Password:
Sorry, try again.
Password:
==> /usr/bin/sudo /usr/sbin/chown aun /usr/local/. /usr/local/bin /usr/local/include /usr/local/lib /usr/local/lib/pkgconfig /usr/local/share
==> /usr/bin/sudo /usr/bin/chgrp admin /usr/local/. /usr/local/bin /usr/local/include /usr/local/lib /usr/local/lib/pkgconfig /usr/local/share
==> /usr/bin/sudo /bin/mkdir /Library/Caches/Homebrew
==> /usr/bin/sudo /bin/chmod g+rwx /Library/Caches/Homebrew
==> /usr/bin/sudo /usr/sbin/chown aun /Library/Caches/Homebrew
==> Downloading and installing Homebrew...
/usr/local/Library/brew.sh: line 140: /usr/bin/xcode-select: No such file or directory
You must: brew install git
You must: brew install git
Error: Git is unavailable
Failed during: /usr/local/bin/brew tap homebrew/core
Auns-MacBook:~ aun$ brew install git
/usr/local/Library/brew.sh: line 140: /usr/bin/xcode-select: No such file or directory
You must: brew install git
You must: brew install git
/usr/local/Library/brew.sh: line 140: /usr/bin/xcode-select: No such file or directory
You must: brew install git
You must: brew install git
Error: Git is unavailable
Error: Failure while executing: /usr/local/bin/brew tap homebrew/core -q
Auns-MacBook:~ aun$

Can you tell me what is wrong?

Thanks

To be honest: this is the forum for the Windows program MP3tag.
It is not the Mac OS hotline,
it is not the support for puddletag.

There have been a number of suggestions how to get around the problem. I think you should try these first:

  • move the files or some of them to an internal drive so that the network address disappears
  • get another Windows installation and see if it works there.

Also: get more knowledge about your OS.
It could also be that the access permissions are not sufficient - even though the paths do not match Windows standards, it could well be that MP3tag only issues an open file command to the OS and that then has to take care about getting the file.
Still, it could also be possible, that esp. renaming or moving paths then has to be as close as possible to the original OS so that you need a dedicated emulator.

I have tried referencing an internal drive. The network address doesn't disappear. If you read my earlier reply. I tried using the iTunes subdirectory on the internal volume and even so, it is showing up as:

"\\?\unix\Music_1\iTunes\iTunesMusic"

The internal drive shows up as "/" the subdirectory "Macintosh HD" under that and mp3tag appends \\?\unix to whatever Mac OS X drive I reference be it internal or external. It does not work on an internal drive either.

my thanks to garym for being the most patient and helpfull. I am replying here about puddletag because he suggested it to me here.

My apologies for asking for help here. I have tried all the suggestions given here. It appears that no knowledgeable help is forthcoming. It is just strange that a Mac OS X version is there at all when it clearly doesn't work and no one really knows how to make it work.

Adieu

All of it is revealed at
http://www.mp3tag.de/en/mac-osx.html

Did you notice that there are 2 versions available? One for Macs with Wine already installed and one where it isn't?
Which one did you take?
Is Wine uptodate on your system?

As this application works fine for a number of users, it looks like we have to focus on the environment on your system. If that is right then MP3tag will work.

That a genuine Linux program also does not work (here: puddletag) would make me think.

I've never used puddletag....I just have seen references to other users liking it because it works as a native OSX program and has many of mp3tag's functions. I'm not sure if there is a puddletag forum for help. Also, keep in mind that there is no OFFICIAL mp3tag OSX version. Third parties have made it work with a windows emulator and packaged this all together. Then mp3tag provides a link to these packages. But they do note that "Please note that those packages are not officially supported, but we do our best to keep them working on your MacBooks." I do know several happy users of mp3tag on OSX machines, so I know it does in fact work on Macs. Your "?" issue is not normal for a MAC volume location, thus the need for additional workarounds.

My earlier recommendation is what I would pursue: Copy these files to a USB drive and read them on a friends WINDOWS machine running mp3tag. Good luck.