Save tag keyboard shortcut quit working

Ctrl-S keyboard shortcut has stopped working. I have to click on the item and use the dropdown list to save changes.

I have tested Ctrl-S in other applications and have used an online keyboard test which both indicate my keyboard is working correctly.

I would appreciate any suggestions. Searched online help but found nothing there

Are you using any software that remaps keyboard shortcuts or intercepts your input in some way? Also, do you have any files selected when using the keyboard shortcut?

no known remaps. no other software running at the time. Loaded data from a directory of audio files. Sorted on three fields for editing. Only change is to insert data into Discnumber field, then tab out of field and do Alt/S. Nothing happens. Have to click on the row again, then select SAVE from drop down to get it to save.

Online keyboard test verifies that Alt/S is working.

The keyboard shortcut to save is Ctrl-S, not Alt-S.
There is no shortcut function assigned to Alt-S.

Ohrenkino, sorry, the disconnect is between my brain and my fingers. I should have said Ctrl-S. I have always used the left-hand Ctrl key, but have also tried right-hand Ctrl also, to no improvement.

I have reinstalled MP3TAG, and have also reinstalled an older version, but still have the problem, so should be using the default shortcut settings. What with several years of work on my collection of 70 K tracks, I supposed the keyboard might be failing although the other typing seems to be OK.

Maybe this is an excuse to get a new machine! I'm guessing well over half a million saves. I currently have seven storage boxes of CD's in my office working through verifying the tracks are all in my collection. CD cases are all labeled on the spine and numbered, so I'm using Discnumber tag as a reference to the storage location.

I would start with another keyboard - just to be sure you really need a new machine :innocent:

One last attempt could be to rename the MP3tag.cfg file and see if things turn to the better.
If not then you still have the original settings.
If it gets better, then the file got corrupted for whatever reason and cannot be used any more. You will loose all previous adaptions, though.

There is no config file, I would assume because I have not saved a configuration, so figure it is using a default. The right-click drop down menu does show Save Tag and that does work.

The .ini file contains:


Is there possibly something missing under [shortcuts] ?

This is intriguing since last time I worked on this project last winter all was working very well. I had not reinstalled the program since trying a new version then. Still running the same OS, and really haven't done any major system changes either.

And as I said earlier, an online keyboard test does indicate keystrokes for Ctrl and for S.

I think my next try will be to install MP3TAG on the machine that I actually use for my live music files and see what happens there.

There should be. it is called mp3tag.cfg
It gets created the first time you use MP3tag.
The file that you quoted is the file Mp3tagSetup.ini which has nothing to do with the ordinary operation.
See this thread for possible locations of MP3tag data: