Selecting multiple files causes view to shift to the left

This is a funny behavior quirk that happens occasionally.

I use a lot of columns. If I've sorted files by a column on the far right and I'm looking at that column, and want to select multiple files, I click on one file, scroll down, hold down the shift button, and click on another file. Sometimes, this causes the view to shift all the way to the left. When the view shifts to the left, for a split second all the files disappear and I see I see a bunch of scrambled funny characters. It doesn't happen every time though. I think it might be related to how long I'm holding down the shift button after I left click, but I'm not sure.

Because I have so many columns, it takes a while to scroll back to the far right and that interrupts my workflow and that gets especially tiresome when I am working with many thousands of files, and need to focus on only a few at a time, and it keeps happening over and over.

Thanks for your time! I love this program.

Thanks for your feedback and the detailed description of the issue. I think I've read this before and it's very similar to what has been described here:

List focus jumps to first column after selecting multiple rows

Unfortunately, it's one of the open bugs and I have currently no idea on how to fix it. I'm looking into it from time to time, with the hope of finding something, but so far it's been not successful.

I'll definitely keep and eye on it and keep you posted when I find something.

Thanks for your quick reply, Florian! Yes that is the issue. I'm not surprised it's proving difficult to nail down.

I have an interesting observation about this. I just tested it now. If I continue to hold the shift button down for a second after I left click it does not happen. It's a workaround at the very least, if not an additional clue.

I've spend some time on this over the past few hours and identified a potential cause for that. Can you try this internal version and check if the issue persists (and if other issues appear)?

Thanks Florian! This seem to have fixed the problem of shifting the view to the left.

However, now every 5th time I press the shift key when making selections, I get a Sticky Keys pop up that says "Do you want to turn on Sticky Keys? Sticky Keys lets you use SHIFT, CTRL, ALT, or Windows Logo keys by pressing one key at a time. The keyboard shortcut to turn on Sticky Keys is to press the SHIFT key 5 times. Disable this keyboard shortcut in Ease of Access keyboard settings."

This happens every 5th time even if I do not make the selections in rapid succession, and it seems to happen when I release the SHIFT key, not on pressing it or left clicking.

Unchecking the box next to "Allow the shortcut key to start Sticky Keys" in Ease of Access keyboard settings fixes this problem, and everything works perfectly.

Success! Thank you so much!

P.S. I just made a donation! Thanks again.

This is excellent news! The workaround I've used is highly unconventional and might break this — that's why I was a little bit cautious.

Is the Sticky Keys pop up something you won't get when using the previous version? I've tried to reproduce it locally under latest Windows 10 and it didn't appear. It would only appear if I click the Shift key 5 times, but not while performing a selection.

Can you describe a sequence of clicks and Shift key presses that would trigger the pop up for you?

Thank you! I've just sent you a short Thank you email :slight_smile:

I uninstalled version 3.04b and installed 3.04a, and I do get the same behavior.

Here's the sequence. I left click on a row. I hold down the shift key and left click on another row to select multiple rows. I repeat these actions five times. The Sticky Keys pop up appears and I hear a beeping sound.

I've experimented a bit, and I have found that this behavior seems to be related to a Jelly Comb USB touchpad I am using. It does not come with it's own drivers. It uses Windows generic drivers.

I tried using a USB mouse with the same keyboard I was using and I did not get the problem. I also tried a Logitech K830 wireless keyboard with built in touchpad using up to date Logitech drivers and there was no problem.

So that seems to narrow it down.

I'm not able to locate a model number for the Jelly Comb touchpad. It seems to be a nice functioning unit other than this problem.

Many thanks for looking into this! I was worried that the behavior regarding Sticky Keys was related to the workaround I've added.

Good to know that it's not causing any issues so far! And very helpful that you took the time to compare between the different versions.

I've been using MP3tag a lot in the past 24 hours on a big project (30,000+ files) and everything has
been running very smoothly. Glad I could help. Your dedication is inspiring! :smile:

1 Like

This is now fixed with Mp3tag v3.05a. Thanks again for reporting and for testing the intermediate versions!

Great news! Thanks so much, Florian. Glad I was able to help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.