Suggestion: new Action: Convert Russian characters to Russian Unicode


I like to listen to some Russian mp3s on my computer and iPhone. Problem is that many of them contain russian codepage characters, so it looks like this: Íîâûé ãîä 2006

Would it be possible to add the ability to convert from Russian Code Page Characters to Russian Unicode?

I'm sure I'm not the only one with this problem. I have searched the internet for solutions, but unfortunately the only ones I have found are scripts that run only on UNIX.

Anyhow, please take this under consideration because I think it would be quite easy to implement, seeing as mp3tag can already do such similar things as Case Conversion.

It's already possible:
Make a new action and choose "Convert codepage"

1 Like

I do not see "unicode" destination in the list of offered code pages, or I'm missing something?

You must select the Russian codepage. Mp3tag always converts to Unicode, you must select the current encoding of the tags.

My mp3s tags already in Russian CP1251 encoding, what I want to do is convert it to
unicode. I do not see how you can do it with convert to code page action, if there is
other ways it would be great.

Please try to understand what I wrote.

When your tags are in cp1251 you must select cp1251 in the codepage conversion.
You must choose the current codepage of your tags. The action always converts to unicode.

what dano suggests, works... I converted to unicode mp3s myself before using his instructions.

I have similar problem.
When I try to convert the tags to unicode using "new action" and choose "Convert codepage", I get all "????????? ???????" instead of letters.
What should I do?
Thank you

.mp3 not work correct, but .ape work correct!
Win XP 3 SP English version.
Mp3tag ISO-8859-1.

You cannot save russian characters in ISO-8859-1
You need unicode.
In "File > Options > Tags > Mpeg" you must select utf-16 or utf-8

But after coding in utf-16 or utf-8 are many problems in other programs (Sound Forge, ...)!


I had the same problem. My Fiance likes Russian music and all my characters would be changed if they were not unicode. There is a very simple way to fix this. It is in the language settings of Windows.

I am using Windows 7 so I am not sure how to fix this on previous versions but I imagine it is similar. Go to Control Panel-Clock, Language, and Region then click change display language. go to the administrative tab.

There is a section there for language for non-unicode programs. Click the button for change system locale and select Russian. Now when you download new music windows will keep the right characters when you add them to the library.

If you have already added them to the library and the characters are wrong then this fix will not correct them for you as the characters have been saved as a unicode tag. Going forward the problem should be solved.

I just figured it out today and it has worked so far.

Hope this helps you guys out as well.