Tags not saved in mp4 files

I'm trying to add titles, album, artist tags to a set of mp4 files. No error shows up when I tell it to save the tags, but the files do not have any tags in them. As a result this software seems totally useless. What am I doing wrong? I've tried several versions of mp3tag including 2.53 with no change in behavior. I don't see any way to make it work and there is no documentation pointing me to what I'm doing wrong.

Do you mean that after saving the tags in your MP4 files, the tags are also not shown in Mp3tag?

Yes, there are no tags showing in mp3tag. And exporting tags yields nothing but the filename.

Is anyone using mp3tag to tag mp4 files? I've had no responses as to whether this is possible, but it seems to indicate that it is in the documentation. There are many choices to edit tags in mp3 files, but not much for mp4 files.

It's possible and usually it works.

You can try to remux the mp4 files so they get a new and clean container.
Google "mp4 remux" or similar.

That isn't very practical, as I have a fairly large number of mp4 files. Why would that matter?

Try it first to see if it helps.

I have the same issue. Some files the tags are saved correctly other files I get the "Writing Tag Data" message followed by "Saved tag in 1 of 1 files" but the tags haven't be saved. I cannot see an obvious difference between the files for which it works and those it doesn't. I have tried remuxing using XMedia Recode, I have tried removing all tags first. The files are writable, they are around 4GB (but not the largest I have tagged).

Any suggestions for how I could debug this would be welcome.

I'm using Mp3tag v2.54. The front cover image can be added OK through "Extended Tags".

I've just tried remuxing with ffmpeg and still the tags are not written!

I have tried remuxing adding a couple of tags as part of the remux process. Mp3Tag actively blanks the ones I am trying to write. Anybody else seen this?

Hello I have a collection of around 200+ mp4 files, most of these have been re-encoded into the mp4 container. They use the m4v file extension.

I have used mp3tag to tag my whole collection with artwork and title and year, this has worked well for all but two of my m4v/mp4 files.

I have used handbrake to re-encode files that needed re-encoding. What is interesting about these two files is that the artwork has saved but the title and year fields have not. Looking at the mediainfo for a file where title and year are saved and the mediainfo for one where they won't i can't see any great difference.

I have tried right clicking the file in Win7 and going to properties and selecting the details tab. Here I can add a title to one of the files. This seems to take a lot longer to write the information to the file, I have left it for almost 20 minutes and Windows explorer went into not responding.

This lead me to try winamp which can also tag files. This also went into "Not Responding" almost immediately after initiating the save of the tags, I have left it for 15 minutes I went into task manager and selected winamp by right clicking and choosing "Go to process" to end it, immediately when I did this the program sprang back to life and it seemed as though the tags had successfully written, when I reloaded the file in mp3tag the tags saved with winamp appear to be visible in mp3tag for one of the files but not the other (Strange). I tried this on the second file and the same thing happened where I had to go into task manager and right click winamp and choose go to process, immediately the program sprang to life. On each occasion I left it in not responding mode for about 5 to 10 inutes. The tags for the second file which dont show up in mp3tag do show up in winamp and in windows explorer and on my xbox 360.

This has worked (kind of) on both files using winamp so I would guess there must be some difference in the way winamp writes the tags to the file compared with mp3tag and windows explorer?

Not a fix but perhaps something that can be investigated in future releases of mp3tag? This won't stop me using mp3tag as it is only a few files but would be nice if it wasn't an issue.


There is a German thread that reports about problems when writing tags in MP4 files:
[X] Tags von SimpleMovieX werden nicht erkannt - Datei konnte nicht zum Schreiben geöffnet werden

Apparently, the "File has no MPEG4 IOD/OD" message is important. And perhaps you can check this in your files.

So, solution?
I have just run into this problem, what's the fix?

Encode it properly so that it has the right structure.