This tag code does not work

Hey, I was looking at my older support thread to get the track number 101, etc, in my tags, and I drag over the folder with the songs I did with MP3tag into iTunes, and I look under the track column in iTunes, the track column is not there by default, but every song in that column is blank meaning both the track number and track of are blank and there are no numbers in that column. Am I not following this right? Or is the 101 for CD 1, 201 for CD 2 is a different column? Or could it be simple I was using that code string on a single CD instead of a 2 CD, or even 10 CD set?

Here is my older thread: /t/14321/1

These questions from me are not iTunes questions. The questions I'm asking are tagging questions that hasn't changed since 1996. If I understand how to tag properly then I wouldn't have these problems. My problems are tagging and not iTunes. People tell me to use mp3tag since I'm not understanding the manual way and doing everything incorrect using the disc and track.

Yes they are.
You use iTunes as test bed and iTunes does not display the expected data.
Mp3tag on the other hand does.
The thread you mentioned asks you to perform a certain action in iTunes. Have you done that?

Also, you claim that "people" advise you to use MP3tag: if you have such problems with Mp3tag that you do not understand the simple functions then please ask these "people" to explain it for you.

But like I said in my opening post, the string code you provided me in my thread, it shows no track numbers in the iTunes track column. Could it be I'm using the code and instructions you provided me on a single CD and not on a 2 CD or box set?

What does Mp3tag show in the track column?

Here is the screenshot of the Mp3tag.

Does that show what you are asking?

No. It does not show the field TRACK (And you seem to have a column defintion that produces a syntax error)

And how am I going to fix this both the field TRACK is not there, and the syntax error? I didn't even know I had an error, and that is why TRACK is not there. I followed your instructions exactly.

The dump does not show the field track .. I assume that it is a little more to the right :wink: So if you could either scroll a little to the right so that it becomes visible ...

The syntax error is displayed in a column that has no (visible) title ...
Also it would help if you could select one of the files so that the tag panel gets filled.
then try to screendump again.

Here is the syntax error. I just noticed it.

I do not know what you have done to the track field ... but to get a decent number back into it do the following:

Select all the files of the album.
Select the function Tools>Tracknumber wizard
Tick the option for number padding.
Do not tick the option for total number of tracks.

Does MP3tag now show a track number or still "Syntax error"?

Here are the options I have, which one do I tick?

Save total count of tracks
Leading zeros for tracknumbers (01,02, ...)
Reset counter for each directory

I don't see no padding to tick.

_ Save total count of tracks
X Leading zeros for tracknumbers (01,02, ...)
_Reset counter for each directory

Thank you! It fixed it and now I don't get syntax error.

What would I need to do to tag box sets, single CDs, and multiple CDs?

This is mainly a question of taste...
you can select all tracks from a multiple CD set (already sorted cd by cd in the correct track order) and then use the track number wizard again with the same settings as you have just used.
This will number all tracks sequentially - but you will loose the original track numbers.

Or you apply an action (once) that uses the tracknumber and the discnumber as a prefix. This only works if you have filled the discnumber.
For this the action should be of the type "Format value" for TRACK.
Enter as format string: %discnumber%$num(%track%,2)
This will transform the track number from 02 for disc 1 to 102.
For disc 2 this will transform tack 04 to 204.
You also loose the original tracknumber but you can rebuild it if you remove the discnumber again.

The Format value is my taste because the 104 will tell me that represents the disc number and track number. May you also tell me please if that Formate value would work on single CDs?

Just as I told you:

(If the discnumber is filled then it prefixes the tracknumber - if it not there, then you see only a two-digit tracknumber)

Why didn't you try it?

I am going to try it but I would like to know first if this would work first on single CDs or not?

I just tried this and I'm completely lost.

Here is what I don't understand:

Does all songs across all CDs have to be in one particular large folder of all songs? What if I say that I have each CD has its own CD folder such as CD1 has all tracks of CD1, all tracks of CD2 has all CD2 songs? So all CD songs are not in one large folder mixed together. I am also working on this box set–1989)

Maybe a link to a box set would be able for you to help me because these are not normal CDs? I'm just not understanding.

BTW, that link above, I copied and paste it from a mobile device, so if need remove the "m" and put in something like "www" to access on PC.


That's alright for me.
The only pre-condition you have to meet is that two fields are filled:

Then go ahead and run the action.