V.3.16 x64 upgrade fails to install context menu

I tried to uninstall x32 and then install x64. I selected the context menu option during the install, which had already been installed in the x32 version. The x64 install hung up with the message: Staging Sparse Package failed C:\Program Files\Mp3tag\Mp3tagShell.msix. Windows cannot install package 35795 Florian Heidenreich.Mp3tag.ShellExtension_3.15.0.0_x64_hyhc94k68ebpm because it is already installed with a different external location.
Next I tried uninstalling x64, reboot, re-install. Same error

Mp3tag v3.16 - 09.06.2022 - 09:33:29
OS-Version: Windows 11 (build 22000), 64-bit
Build: May 30 2022 16:20:46 (64-bit)
AppPath:  138.922.868.736 Bytes frei (C:\Program Files\Mp3tag\)
DataPath: 138.922.868.736 Bytes frei (C:\Users\mtreloar\AppData\Roaming\Mp3tag\data\)
TempPath: 138.922.868.736 Bytes frei (C:\Users\mtreloar\AppData\Local\Temp\Mp3tag v3.16\)

Have a look at this thread:

You can try from a command prompt with admin rights:

cd C:\Program Files\Mp3tag
powershell -c "Get-AppxPackage -name *mp3tag* | Remove-AppxPackage"
powershell -c "Add-AppxPackage Mp3tagShell.msix"

I don't have an explanation for the error you're getting, though. If you've uninstalled, it should now longer be available and installing on a new location should be now problem. If you have any details on the type of user account you're using (and if it differs from the installing user account) or anything else that might give a hint regarding the cause, I'd be happy to know.

Thanks Florian. I tried the powershell commands - same error (see picture below). I am using a standard admin account and it is the same as I have always used. It is windows 11 pro, upgrade install from win 10 pro, and an insider build, but not on the bleeding edge: 21H2 22000.708

Forgot the graphic:

OK, thank you. Can you send the output of

powershell -c "Get-AppxLastError" and
powershell -c "Get-AppxPackage -name *mp3tag*"

I uninstalled x64, reboot, reinstalled x32, reboot, uninstall x32, reboot, checked right click menu with Nirsoft Shexview and shmnview - nothing there, then reinstalled x64 successfully without the error message. However, now I have the context menu item mp3tag, but it does nothing.

No output from the first PS command line.Here is what I got:
PS C:\Program Files\Mp3tag> powershell -c "Get-AppxLastError"
PS C:\Program Files\Mp3tag> powershell -c "Get-AppxPackage -name mp3tag"

Name : 35795FlorianHeidenreich.Mp3tag.ShellExtension
Publisher : CN=Florian Heidenreich, O=Florian Heidenreich, S=Sachsen, C=DE
Architecture : X64
ResourceId :
Version :
PackageFullName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_3.15.0.0_x64__hyhc94k68ebpm
InstallLocation : C:\Program
IsFramework : False
PackageFamilyName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_hyhc94k68ebpm
PublisherId : hyhc94k68ebpm
IsResourcePackage : False
IsBundle : False
IsDevelopmentMode : False
NonRemovable : False
IsPartiallyStaged : False
SignatureKind : Developer
Status : Ok

Glad you have the context menu now. It's one step in the right direction.

Regarding the "it does nothing", can you follow the steps in this topic and report back?

Well, maybe the program did not register properly. The first 2 keys are not there at all
HKEY_CURRENT_USER\SOFTWARE\Florian Heidenreich\Mp3tag\Install\InstDir HKEY_CURRENT_USER\SOFTWARE\WOW6432Node\Florian Heidenreich\Mp3tag\Install\InstDir

The next is OK I think

The last one is not there at all
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Florian Heidenreich\Mp3tag\Install\InstDi

This all looks good — not all of the keys must exist, it's enough to have one of them. If the InstDir points to the correct installation folder (can you check that?) it should also be able to open the app.

One last idea is to check the Windows event log.

Windows event viewer reports an error as below. WER reports are in the zip attached

Fault bucket , type 0
Event Name: MoAppCrash
Response: Not available
Cab Id: 0

Problem signature:
P1: 35795FlorianHeidenreich.Mp3tag.ShellExtension_3.15.0.0_x64__hyhc94k68ebpm
P2: praid:Mp3tag
P3: 10.0.22000.1
P4: 93f44fbf
P5: Mp3tagShell.dll
P7: 628cb862
P8: c0000005
P9: 0000000000008bbb

ContextErrorLabdoc.zip (5.0 KB)

OK, thank you. I can't pin-point the source of the problem. Does it happen everytime you click the Mp3tag context menu item, or only if you select multiple files or folders?

Happens on one file, several files and directory. Consistently. OTOH, if I use context "Open with" it works OK. I don't know if it matters that the files are all flac.

Yes, "Open with" is something different and doesn't involve the shell extension.

I've created an unofficial version that includes extended error logging to a file Mp3tagShell-####.txt on your Desktop. This means, this version is only made available with the intention of gathering more information on the crash you're experiencing.

It would be great if you could install this version and reproduce the issue with different scenarios (one file, several files, directory) and send me the log file(s). You can also do so via PM, in case you don't want to share file paths logged to those files with the Internet.


Hi Florian, Check your PM for the log files

That's very helpful, thanks for the quick reply!

I've created another test version with even more logging (and a potential fix). Can you try again?


Check your PM. Works!

Excellent! Glad it's working now and thank you for helping me in finding this issue.

I'll release an official beta version soon, including the fix, so you don't need to get your Desktop crowded with all those log files!

Thank you for the fast fix.To stop the desktop clutter, I have uninstalled the program until the new beta arrives.

This is now officially fixed with Mp3tag v3.16a. Thanks again for reporting and your help!