Web source errors

I keep getting the following error whenever I try to use either the basic discogs tag source or the pone mod:

"Error connecting to server: www.discogs.com >> 401 unauthorized".

Whenever I try the other tag sources, all I get is:

"Sorry, no entries are matching your search criteria."

I'm a very new user of MP3Tag and discogs, but near as I can tell, I followed all of the steps in the help files and the instructions for the Web sources exactly, including enabling MP3Tag in my discogs account and copying the API key to MP3Tag.

Where should I start with troubleshooting this? What field(s) should I be searching on (for classical music)?

No one has any ideas? :frowning:

I'm having the same problem with getting tags from Music Brainz. no matter what I try I get a pop-up message that says 403: Forbidden
I've looked in the profile folder at the .src file. taken the HTTP address out and tried to use it in my web browser (firefox). It appears to return data in the web browser. I then checked my firewall, and explicitly set up a rule to allow it through; no joy, same error.
So, then I noticed that the .SRC seems to have a DEBUG file specification, but it's commented out. I remove the comment; change the file to drive it will write to. and no joy; same error.

Similar issue with using discogs; it just says no items returned no matter the criteria.

I'm out of ideas. Any one can point me in the right direction?


Please check you system date and time.
Maybe you changed it accidently or you mainboard-battery is low.

I have the same problem with tag source connection being "Forbidden" to discogs and musincbrainz
Amazon.com/.de don't throw an error but also don't find anything also for well known albums

Windows and DOS date and time are correct.

Any idea what might be the problem?

Perhaps you blocked MP3tag in the firewall?
Use Help>Check for updates
to get a message box telling you that you are either uptodate or not.
If there is no message box, then MP3tag is blocked.

I get a message box that my version is up to date.
So firewall should not cause the issue.

Any other idea?


I have the same issue, am new to the forum but not mp3tag itself.
The errors are 401 & 403 but always related to Discogs - and only appear when using mp3tag's out-of-the box script for Discogs. The funny/strange thing is: I have a valid token, revoked/renewed it, and it did work last week. But by now, mp3tag no longer asks me to enter one. Is there a way to force the dialog? I suspect the tool just doesnt provoke getting the new key.

And then even more strange so, playing with Pone's scripts (although I find them pretty tough to handle since new), it appears that those scripts actually CAN access Discogs even without asking for the token and querying for artist/title data on the Discogs server works. Just when I try to actually modify some mp3s with that data, they arent getting the tag updates.

I am lost in this, as I cannot see the pattern where it actually fails.
How come one script can access, the other cannot, while I cannot find that the scripts themselves store the auth data anyway. Plus, Firewall is definitely open (again, one of the scripts seems to be able to access).

Can anyone please have a look?

Thank you!

here is a thread from 2016 about teh 401 error:

OK, that's the explanation for discogs. Problem occured on Win XP (I manage my music collection on an old PC that for most purposes works fine). Is that also cause of issue with other tag sources (freedb, musicbrainz, amazon etc)?