Wine on macOS Sierra

Have been using MP3TAG for years and LOVE IT but....it's not working for me either since upgrading to Sierra :frowning:
Have tried everything suggested in the forums and it's still not working. Have also tried installing via Wine and Wine gives a checksum error. This is driving me crazy and it doesn't look like I'm the only one having troubles - can you please please help as I'm lost without MP3TAG and need it to work.

Thanks to everyone in advance for all the help!!

I still cant get it to work. Looking for an alternative tagging software, any suggestions?

Which of the various steps that have been described in this thread lead to which result?

It is a little puzzling to read that "it works" for some and for you it does not. And as nobody can look over your shoulder from the distance, you have to be as clear with your descriptions as possible.

Have you really checked all steps?

  1. Download the version with Wine included, currently: mp3tagv280-MacOSX-Wine.zip
  2. Delete the previous version
  3. Allow application from verified developers at System Settings > Security
  4. Delete previous settings from /Users//Library/Application Support/de.mp3tag.Mp3tag_*
  5. Unzip mp3tagv280-MacOSX-Wine.zip and copy Mp3tag.app to your Applications folder and run it from there
Kind regards – Florian


Newbie to the forum! Literally my first post... Anyways, I am having the same problem. I was previously using 2.79 and it prompted me to update to 2.80. After doing so, I am not able to open the application.When I click on the suggested links to download from this postI get: "Not Found The requested document was not found on this server. Web Server at mp3tag.de". I have tried ALL that you have suggested above and have had no success. I love this program!!!!! Please advise, PLEASE.



I've fixed the download URL which pointed to the previous version. Can you download the current version and try the steps outlined above?

Kind regards
– Florian

This worked perfectly. Thank you so much Florian!

Glad you got it working! And thanks for talking back :slight_smile:

Kind regards
– Florian

I followed all 5 steps above, and nothing. The first time I opened it, it asked me if I really wanted to open it, and I said yes, and it closed. Then, every time I tried to open it, it appeared for a fraction of a second in the dock, and then closes, and that's it.

Then, I deleted the application support settings AGAIN, and now it opens.

Weird.

Hello,

I followed all the same steps, I have not yet had an old version off mp3tag.

I have downloaded and installed mp3tagv280-MacOSX-Wine.zip

But wen I open it it appeared for a fraction of a second in the dock, and closes and it keeps doing this by all the times I try.

Here is a screenshot of the Application support folder.


Please someone help.


This looks like the Application Support folder found at
/Library/Application Support/

Can you please navigate to
/Users//Library/Application Support/

and delete any folder that starts with de.mp3tag.Mp3tag_*

Kind regards
– Florian

Yes,

Thank you, the folder library was hidden. I have found it now en deleted the mp3tag files. And now it works.

Thanks again for your quick reply

Florian, I am having the same problems as those described above. I have been using Mp3tag in a Windows virtual machine under Parallels for several years, but after upgrading to MacOS Sierra I decided to scrap the virtual machine and Parallels because my MacBook Pro was running so slowly. In the process, I lost Mp3tag, although in Finder I still had the .exe files.
I have carried out the first 3 steps described above, and the opened .exe file for the downloaded latest Mp3Tag version with Wine is in my Applications folder. All my other versions have been sent to the trash. But when I try Step 4 (...User/Speed/ Library/Applications Support/etc...) I cannot find an Mp3Tag file anywhere to delete.
When I double click on the Mp3Tag icon in my Applications , I get nothing..It just seems dead.Can you help, please?

I'm having exactly the same issue and just posted a new thread about it (sorry, it was before I found this one!)
I'm running it from the apps folder and it won't open.
Please help
Thanks

This has already been answered above but it took me ages just because I couldn't find the library folder which is hidden by default.

Just do a Google search for "how to open hidden files on a Mac" and then copy and paste the command into terminal.

Then navigate to the library folder (if you are in the right place the library folder will be greyed out but you can still access it.
That's where you will find the "Application Support" folder and in that the ".deMp3Tag..." folder. You have to delete this and then re-install the app using the link on the MP3Tag site with the Wine installer included.
Do not run the MP3Tag app from the Downloads folder, be sure to copy it into the "Applications" folder and run it from there and everything should be fine.
I know this has all been explained by Florian before, but maybe some people missed the fact that the library folder is actually hidden.
Cheers

The command which needs to be entered in Terminal.app is

defaults write com.apple.finder AppleShowAllFiles YES

You might need to restart your Mac, for the changes to take effect.

Kind regards
– Florian

Hello

I have the same problem.

How can I fix it please ?

Follow the steps described in this thread.

Of course I do it but doesn't work...

As the other users reported that it does work, you have to help a little:
which step lead to which result?