Write Error Attempting to Save Tags

Getting intermittent errors (see below) when saving tags. Not a network drive. Any help? Anyone else get these?

I have checked, there is no other program with the files open when this happens.

(second topic is in German)

bumping this question...

I've had mp3tag on my computer for a while now, and have used it OK before. Now I'm getting the same 'Can't open file for writing' message as the OP.

It only happens with some files. For example I can choose one album, try and save album art (cut and paste from google or amazon), and it won't write to the tags. I choose the next album, go through the same processes, and it writes 'OK'. But if I go back to the first album it still won't work.

The tags seem to be the same to me, they're all listed as ID3v2.3 (ID3v1 ID3v2.3).

I'm afraid I'm not a tag expert, but if anyone can help I'd be grateful. Is there any way I can check that the 'bad' tags are the same as the 'good' ones, or find out how they might be different?


(Edit - sorry - meant to say I checked through the earlier thread referenced by pone, and I don't have foobar or anything like that)


This is always an operating system problem, particularly Wz which constantly looks for changes.
W7 generates thumbnails, updates its search index, (all explorer topics) and the good ole WMP has its fingers in those folders.
Ah yes: and if you like a slideshow to change your desktop background or play it as mini application then you have the wmp running in the background.
So: unless you open once and save all the changes in one go, it is fairly likely that one of the above processes has grabbed the file and blocks it for other programs.
(I dunno: I have tried to move folders with recently updated music files and W7 wouldn't let me delete the thumbs.db as it is "currently in use" although there were no more files in that folder....)
To cut this long storyort:
a: blame it on windows
b: save all changes in one go and not one modification and then the next. Or leave a grace period for the other nosy programs to calm down.

(my keyboard just went up the spout - so I had to insert a couple of the missing letters)

Rather often the file access can be freed by user logoff - logon procedure.


thanks for the replies.

It could be some other programmes grabbing the files, but I don't have any slideshows open; don't often use WMP etc.; I do have mediamonkey on my machine, but not open at the same time as I try to tag with MP3tag. In fact the only thing that's obviously running is IE in order to find the album art I'm trying to add to the tags.

but - it's always the same 'bad' tags, so I think there must be something else going on?

It's also the same tags if I shut down the PC and come back to it. I have something over 12k so I don't want to have to start again!

Are there tools on MP3tag that can choose a certain number of fields and then automatically amend all tags, deleting fields I'm not interested in?

..... but on the other hand, if I can't access 'bad' tags I suppose that wouldn't work either.

Any further suggestions? Please!

You could save the album art first to the file system and then import it.

Just a shot in the dark ...

Open Mp3tag and load one of the 'bad' files into the list view.

Select this file.

Execute 'Mp3tag/Edit/Cut' or press [Ctrl]+[X].

Execute 'Mp3tag/Edit/Paste' or press [Ctrl]+[V].

Open the dialog 'Extended Tags...' and within there use the dialog 'Add cover...' and get a cover picture file from the file system.
It should be possible to load a picture file with filetype as allowed (jpg|jpeg|png).

Leave the dialog 'Extended Tags...' by pessing [OK].

Check again the tag content of this test file by using the dialog 'Extended Tags...'.

Come back to this thread and report what do you have experienced.


This could be very handy in tracking down these errors.


thanks for the continued interest and suggestions - it's appreciated.

I tried as ohrenkino suggested: saved the album art to the file structure and tried to add it from there - but I'm still getting the 'tag can't be opened' message.

I then tried Detlev's suggestion, and got as far as trying to 'cut' the tag. I got the dialogue box asking me if I was sure I wanted to do this; clicked OK; and then I was back to the 'tag can't be opened for writing' box.

It very much looks as if MP3tag just can't access this tag at all, even though it can obviously read it, and display the data.

For whatever it might be worth, I usually rip cds using EAC, then the LAME encoder, accepting album data from a freedb. server. Could this be part of the problem?

Haven't tried the 'technet.microsoft' link yet.

As I say, thanks again for the suggestions.


This is a good information from where we can start further investigations.

I can simulate the situation with the error message 'File ... cannot be opened for writing', when I use a 'ghost' mp3 file.
A 'ghost' mp3 file, so called by me, is a file with the extension '.mp3', but not a completely valid mp3 file at all, for example it has a size of 0 Byte.

If your 'bad' file is larger than 0 Byte and it can play music, then this possibly points to corrupted meta data within the file.

So it would be of interest, how such a 'bad' file of your collection looks internally in byte view.
Are you able to provide a file for further investigations?

You can try yourself to repair such a 'bad' file using foobar2000's header and stream repair utilities.
(foobar2000, file context menu options, Fix VBR MP3 header, Rebuild MP3 stream)


They are larger than 0 bytes (typically about 7-10mb) and can play music.

I'd be delighted to do that, just not sure how. I'm guessing by 'byte view' you mean something more than the extended tag itself?

Thanks for this. I haven't heard of Foobar, or looked at it, but I'll go and check it out now.

and thanks again for continued interest.




..and just to further confuse things....

I installed foobar2000, and tried the 'fix VBR mp3' header command on a selection of the 'bad' files. It came back and said "could not process item (Access denied)".

So, it does look like there's something else 'grabbing' these tags and not allowing other programmes to use them. That's MP3tag; Foobar; and Media Monkey can't access these tags.

I'm just going to delete one album and try ripping it again, entering the data myself rather than using the freedb. data. I'll see if that makes any difference.


Finally (?) I deleted the files for one of the albums that was consistently 'bad'. I re-ripped the CD, using EAC and LAME, but this time adding all the data for album, artists, track etc manually rather than taking it from freedb.

It's back in MP3tag, and allowing me to edit the tags, and so add album art.

If I'd had to do all of the albums manually this way the whole process would have taken an awful lot longer, so perhaps it's worth going the freedb. route (which works in 95% of cases - at least for me) and then sorting out the 'problem' albums later?

So - still don't know what the problem was, but I've worked my way around it. Some sort of corruption on the file as Detlev's suggested?

Thanks for your help & support.


You have reported two different error situations.

So there was more than one problem.

But now we have lost the chance to find out what has been going on before to your files.
Perhaps some of your utilities had a 'bad' day.
Noted as problem solved - at least for you - and that is crucial.


Ah well - it seems I was too hasty in assuming the problem was solved. So, if anyone's still willing to keep digging into this....

Actually I don't think so? I think these are two programs (Mp3tag and Foobar) both running up against the same problem - that the files seem inaccessbile.

I think you're right, that there is something basic going wrong with these files. Because it's so consistent, I don't think it's a "bad day" either! :rolleyes:

I was inserting art into tags today - doing OK up to a point and filling in 'blanks' further up the alphabet. THen I got down to the 'T's - where I'd left off the last time I was doing this in a concentrated fashion. Beyond that point, none of the tags are accessible to me. I don't mind going back and re-ripping the occasional album, but this is something more.

I'm happy to provide a file in 'byte view' as suggested above - to see if that offers any clues. Could someone tell me how to do this?

As always, many thanks.


Sorry, but I do not understand what you are telling.

I suggest, that you provide a small file, which seems to be corrupt, and mail it as zip packed attachment to support@mp3tag.de.
Do ask the developer Florian Heidenreich if he is willing to check the file for technical defects.


What's your OS?
If you make a copy of the file can you edit that?
If you run Mp3tag with Admin rights does it work?

Just to close this off, and to thank all who contributed.

The problem was actually quite simple, and centered on file accesses/permissions. I'd forgotten 2 things - 1) that I'd changed computers, and because of the size of the music files, we'd just lifted the f: drive from the old machine into the new one 2) I'd set up different 'user accounts' on the new machine so that I could allow the kids access on a more restricted basis.

Somewhere in this process the permissions to write and modify files on the F: drive had been turned off for me, even as the administrator. So, nothing in fact wrong with Mp3tag, just a simple settings alteration. Should have remembered it earlier, but I assumed I had full read/write access to all the drives.

Given the lenght of the process to rip all the CDs; then digitise the Vinyl and cassettes; and then try and find album art; it's surprising how something as significant as changing a computer can be forgotten.

Thanks again