[WS] iTunes

#297

Yes. Try the scripts that are linked in this post:

1 Like
#298

Thanks for some reason yesterday the script did not work. Redownloaded it today and it works (The one from github).

#299

As the script stopped working for me too I changed it according to your suggestion last week and it worked again.
Today I noticed that again it stopped working. I reversed the script like it was before
sayregexp "(?<=\"collectionId\":)\d+?(?=,)" ", " "}"
and now it's working again.

#300

Its not working here too. Can anyone upload new working script? Thanx.

#301

The script is broken. Track tags are not shown.

#302

The Original script mp3tag Version v2.90a working again. (was yesterday)

#303

Hello, when I want to open the file, there is nothing. Is there a password?
My script does not work anymore ..
Thank you :slight_smile:

#304

#305

Hey there,

please find attached my working scriptAustria (1200x1200).src (8.9 KB)

CU Steve

#306

SLB, great work. Everything works perfectly. Thank U very much!

#307

Why Composer info of the song is not the same in iTunes and in this script? iTunes have much better (full info) there, but in this script we dont get that

for example

itunes info

info from script

how to fix that?

#308

Beause COMPOSER is filled with artist.Name!

outputto "COMPOSER"
FindLine "\"artistName\":\""
FindInLine "\"artistName\":\""
SayUntil "\", \""
Say "|"

The Information you're looking for is not delivered by iTunes API!!

Regards,
SLB

#309

Hey Guys, great resources here, thanks to all that have contributed...

I tweaked the script to tailor it for my personal use to search for tracks rather then albums as I am working on fixing tags for a large singles collection.

In order to make it work I had to change the [IndexUrl] to search on song entity, but I kept getting no results until I dropped the %copyright% from the index as that is not returned by the API...

So now my initial search result index shows all albums that that track is found on... It works great for me now, except fr I wanted to show the track time to easily spot which version I have is the best match as a lot of versions of mostly dance music have different lengths...
(I did also drop some sort fields for which I personally had no use)

I am asking for help as I am not strong in the "expressions" dept, and I dont have a clue how to fix my script to show the track time in mm:ss instead of the Track Millis the API returns... Everything else works fine for me... if someone has some scripting knowledge to assist that would be great...

I would like this piece of code to show MM:SS instead of the raw API trackTimeMillis:

LENGTH

FindLine "\"trackTimeMillis\":"
FindInLine "\"trackTimeMillis\":"
SayUntil ", \""
Say "|"	

Thanks in Advance...
Here is a copy of my script for anyone to use or tweak if helpful:
iTunes CDN - Track Search.src (5.9 KB)

#310

I'm now back, i don't know what happened but since the recent changes on the forum, i couldn't post anymore, anyway, i'm keeping the script alive on my personal GitHub (search for jonaaa20 over there), anyway, i'm here to report a issue with a album, this also happens with the Stevehero and other tweaked scripts here...

This is what happens:

After some investigation, seems that this is a issue with their API, when you search for this album on the API, instead of showing the song data, i mean, publisher, track numbers etc etc, it shows the album data (album name, artist name and the year) and then the script fails... is there any fix? that's the only problem on the script.

Oh and i've almost forgot, if anyone is interested, that's my latest version posted on my personal GitHub (attached.), feel free to tweak the script :slight_smile:

v0.3.1.zip (143.5 KB)

3 Likes
#311

Hello guys!

Today, my Mp3Tag source iTunes is displaying the following message:

12002: 12002: The operation timed out

But, my internet connection its ok.
What can it be?

Are you having the same problem?

Thanks!
Best regards,

David Jill

#312

Just a guess: has your PC performed the switch to daylight savings time correctly?

#313

Yes I'm in Brazil and everything is correct

I'm using Windows XP ... It always worked ... It was about 2 weeks ago that I did not open Mp3Tag ... And today, when I went to scan some songs, this message came.

I'm using the most current version of Mp3Tag.

Cheers!

#314

Did you see this thread about TLS and XP?

#315

Ohhh... I dont see this notice. Well, for u, iTunes source is ok today?

Thanks again!

#316

The script is working fine.

1 Like