[X] ARTIST cannot be updated

I've had a Format Values action that copies ALBUMARTIST to ARTIST for sometime now that works fine.

I also have a Format Values action that copies the 1st artist in the ARTIST field to ALBUMARTIST

I created a new action to format ARTIST with just the 1st value by cloning the 2nd action and changing the field to ARTIST.

For some reason this isn't working. I also tried the same format string to ARTISTSORT (successfully) and then using %artistsort% as the format string (fail). I tried again using Convert > Tag to Tag and the same format string. The preview shows correctly, it looks like the changes are being made and the results show that tags were formated but the tag is not actually changed. Oddly if I change the format string to $meta(artist,1) the value is updated successfully.

I also tested on another multi-value field and this only seems to occur with the ARTIST field.

Thanks

I cannot reproduce this.
ARTIST can be updated as single or multivalue field with the source being various single and multivalue fields.
Also, the contents of ARTIST copies as set with $meta(artist,0) and $meta(artist,1)

Perhaps you have to check the column definition for ARTIST and see if it says
$meta_sep(artist,\\)

also, the possibility of typos (a % where it does not belong) should not be ruled out.

I checked the column setting and the value for ARTIST is set to $meta_sep(artist,\\).
I also cloned the working action so the only opportunity for a typo was in naming the new action. All the other values were cloned.

You write that you changed the field to ARTIST but your given quotes show the same values.

To be honest: to me this looks a lot like a local problem. And as I cannot look over your shoulder to see what you are doing, you have to your own detective.
Does this happen to all the files or just a couple?
What kind of tags (ID3, APE) do you find in the files? If there are APE tags, remove them and try again.
What does mp3val say to these files? Are they ok or do they have problems? If they show problems, repair them and try again.

I've tried everything. This happens with every file I've tried. There are not APE tags; only id3v2.3 & id3v1. This happened again today on a file I ripped in F2K (what I normally use). mp3cal says the file is OK.

Oddly, the file properties window shows a single artist when I use Convert Tag -> Tag using $meta(ARTIST,0) as the format string for the artist field (the preview here shows Billie Holiday > Billie Holiday as if it doesn't see the 2nd artist) but both the tag panel and results still show both artists. The extended tags also lists both artists.



So to sum it up: you use different applications to check if a multi-value-field is displayed and you find that some applications can do it and others cannot.
To me it looks as though MP3tag behaves just like it should: it shows the contents of multi-value-fields when it is said to do so - in the column definition.
I do not know how the properties dialogue is created, but it could be that it is the dialogue that the OS offers. And Windows does not use multi-value-fields in such a way that it repeats the field label and then shows the contents of all fields with the same name.

If you want to manipulate a multi-value-field, it is best to first merge that particular field, then edit the only one left and then split it again.
On the other hand: the idea to use multi-value-fields might lead to the effect, that the average player cannot deal with it and you loose information for display. (As you have seen: the information is still there in MP3tag).

See also ...
/t/12626/1
/t/13494/1
/t/15443/1

Still the rule is ...
"A multi-value tag-field can not be overwritten with its own first value alone."
... but ...
"A multi-value tag-field can not be overwritten with its own first value alone."
... when you are doing it this way ...

ARTIST <== $meta(ARTIST,0)'\\\\'

DD.20150727.0925.CEST

This has absolutely nothing to do with any other software. As I previously explained, all of the steps I'm doing in mp3tag to split the artist field. The properties dialog is in mp3tag when you right click a file. Again, this has nothing to do with other software or the OS.

Thank you DetlevD!!! I don't know any German unfortunately but this worked!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.