[X] Can't connect to the amazon webservices

I just tried the new version 2.45a.
I can´t connect to the amazon webservices (de/com). The search string for amazon was "Brenda Lee Christmas", so no special characters in it like "?" or "&".

It´s not working with 2.44 / 2.45 also
Here some users describe the same: /t/9041/1

What is the error message? (Press Ctrl+C to copy it to the clipboard and paste it here)
Do other tag sources work?

"Error connecting to server: http://webservices.amazon.com"
The same error appears if i try amazon.fr or .de


Is there are any device or software that may interfere with your internet traffic?
Could be a Firewall, Router, access software or maybe even the provider

How exactly do you connect to the internet?

Sorry but you've started in english and it's in the english forum.
But if you want you can make a new thread in the german forum.

I´m behind a Router (Speedport W501V with Freetz-Firmware).
If i ping it from Win:

ping webservices.amazon.com

Ping webservices.amazon.com [] mit 32 Bytes Daten:

Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.
Zeitüberschreitung der Anforderung.

Ping-Statistik für
Pakete: Gesendet = 4, Empfangen = 0, Verloren = 4 (100% Verlust),

from Linux:

ping -c 4 webservices.amazon.com
PING webservices.amazon.com ( 56(84) bytes of data.
From AMAZONCOM.edge2.Washington1.Level3.net ( icmp_seq=3 Packet filtered

--- webservices.amazon.com ping statistics ---
4 packets transmitted, 0 received, +1 errors, 100% packet loss, time 3025ms

If i try to access "webservices.amazon.com in a browser i get a timeout. I hope this helps

Nobody can reach webservices.amazon.com
It only works with webservices.amazon.com/onca/

What happens if you click this link?

Then i get a XML-File in the Browser (FF 3.5.x)

Does it look like a valid xml? can you save it and upload it here?

Also try this debug script, it should write the file C:\debug_Amazon.com_A.html
How to install:

Amazon.com_debug.zip (1.42 KB)

I installed the src-file in the right folder and tried it with Mp3tag. There was NO such html-file on my whole Harddisk :flushed:

Even if i set another path in the src-file -> no html :unsure:

I tried the second link from the src in FF. To me, it looks like a valid XML. See atachment

mp3tag_amazon.zip (562 Bytes)

You are right if c: is your system partition it does not work (win7 here)
You can start Mp3tag as admin, it might work or better use a different partition.

The link from the src cannot be used for testing, it is not complete.

Has anyone gotten an answer for the webservices.amazom.com problem, not being able to connect?

The current version Mp3tag v2.45c provides some more information within the error message.

My error message is "Error connecting to server: http://webservices.amazon.com >>Bad Request (400)" Any suggestions on how to finally get this working?

Is your system time and timezone correct?

OMG, this is it. My homeserver has is wrong and has changed my dates of all my cpus. Thanks so much, you are a life saver!!!!!!!!!

Thanks, this is it. I had to clear my cmos settings and when I did i reset my system date. Such a rookie mistake!!!!!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.