[X] Horizontal scrollbar resetting

Hello! I encountered a bug with horizontal scrollbar (the one under the list) some time ago and I finally decided to report it because it got very annoying when editing tags every now and then.

The issue is that if you move the horizontal scrollbar to the right (to any non-default position), it will be reset to its default position if you perform any of the following:

  1. Click on any row, then press shift or ctrl and click on another row to make a selection. If you release the shift or ctrl key VERY quickly after doing the second click, the horizontal scrollbar will get reset.
  2. Drag & drop any folder or a file while holding ctrl to add files and the horizontal scrollbar will get reset as well. This bug doesn't happen without holding ctrl.

Sometimes when I can't reproduce the first issue reliably, I just click on any field 2 times to edit it, then press the Esc key. After that the shift/ctrl + click with the quick key release resets the horizontal scrollbar every time. Additionally, I don't think this issue occurs with removing files from the list or at least I haven't noticed it happening.

I am running Mp3Tag v2.82 on Windows 7 (64-bit). You should be able to reproduce the issue with the steps I provided. I tried to record the interaction with Fraps, but unfortunately it didn't work. I can provide additional information if needed. Thanks for looking into this issue, much appreciated.

I could reproduce it - but you have to be really quick. So with the tranquility of older age I hardly come across that behaviour. But it is there.

Using Mp3tag v2.82 on WinXPpro, in the listview I have about 140 columns defined, from which about 60 columns are activated mostly.
As the first and the last column I have defined a dummy column ...
name: _
field: %dummy%
I was not able to detect a bug with horizontal scrollbar within the listview.


Thanks for taking the time to reproduce this! I know that the workaround for the first point is to just click slower, but if I have lots of files to go through, my habit of fast clicking just kicks in and I end up getting bumped to the first of my columns every so often, so I have to scroll right back every time. Also it doesn't change the fact that it's still a bug, so I'd really appreciate if Florian can take a look at it (hopefully he can reproduce it too) an possibly fix the issue :slight_smile:

Just FYI: I've investigated this issue last week and spent quite some time on it. I can reproduce it but unfortunately, I couldn't find any cause for this.

I've even developed a small example program and asked for help at Stackoverflow, but so far nobody was able to reproduce it. Here is the link in case someone wants to jump in:


Kind regards
– Florian

I'm glad to know that you have been investigating the issue.

You have been correct that only 1 entry needs to be selected for this issue to happen. Additionally, I found out that it happens if there is only 1 total entry in the list, it happens with shift and ctrl as well and not only it happens for selecting the entry, it also happens for unselecting an already selected entry.

I can try to reproduce the issue in your test program if you send me an executable (I don't have anything to compile it in atm). Also, did you mention the needed timing in your post at stackoverflow? I can't seem to find that info.


It's not necessary for me in order to reproduce the issue.

Kind regards
– Florian

I was able to reproduce the issue in your program consistently, but I needed to use the same timing as I used for the reproduction in Mp3Tag, which is releasing the shift or ctrl key very quickly after performing the mouse click.

Can I ask why was this moved to the "No Bugs" section? I thought you acknowledged the bug.

There might be a misunderstanding here.

I've reproduced the behavior (in a slightly different way, as described above). I've also developed a minimal example program that uses standard generated code. The fact, that also this simple app shows the behavior makes it very unlikely for me that this is an issue with Mp3tag itself.

So, it really doubt that it's a bug in Mp3tag — maybe it's a bug in the underlying UI libraries or in Windows itself. I simply have no idea and decided to not spend more time with this issue.

Kind regards
– Florian

Well, that's too bad. I tried some googling to see if I can find something that would help. I don't know programming, so I'l just list what I think could be helpful.


I know that you don't want to spend any more time with this issue and I realize it might be a Windows bug or something similar, but I sincerely hope this issue could be fixed one day because it makes mass tagging a very unpleasant experience. I know you are a busy person, but I hope you could look at the issue once more. Thank you again, it's much appreciated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.