[X] Kann kein Cover in MP3 einbinden (wird nach Einfügen nicht mehr angezeigt)

Hallo Florian und liebe Community,

ich habe erst heute gesehen, dass MP3Tag "Made in Dresden" ist - ich wohne auch in dieser wundervollen Stadt :slight_smile: Hier ein kleines Feedback zu einem Problem welches ich mit MP3Tag 2.87b (aber auch alle Versionen vorher) habe. Ich kann kein Cover in meine MP3 Dateien einfügen, nur für FLAC wird es korrekt gespeichert und auch wieder angezeigt. Versuche ich das aber für meine MP3s (ca. 7 Stunden lange Mixe in diversen Bitraten unserer "Wonderful Days" Party, welche übrigens auch in Dresden stattfindet), wird das Cover nach dem Einfügen von MP3Tag so angezeigt als wäre keines vorhanden. Lustigerweise wird es aber in Playern (WinAmp / Foobar2000) korrekt angezeigt, nur MP3Tag findet sein eigens eingefügtes Cover nicht mehr und "tut so" als wäre keines vorhanden (auch in der Vorschau ist davon nichts zu sehen). Die Dateien sind auch nicht schreibgeschützt und bei FLAC klappt alles 1a. Ich habe dazu ein kleines Video gemacht:

https://youtu.be/9pN5-orVzDQ

Vielleicht kann das Problem ja behoben werden?

Vielen Dank und Grüße :slight_smile:

Aus Deinem Video kann man erkennen, dass Du APE-Tags in den MP3s gespeichert hast. In MP3Tag haben Ape-Tags Priorität und überdecken gegebenenfalls andere Tags.
Du solltest mal Deine Einstellungen unter "Tags -> MPEG" zu Schreiben und Lesen überprüfen.
Benötigst Du die Ape-Tags? Wenn nicht, solltest Du sie los werden und mögliche Inhalte nach ID2V2 übertragen.

Danke für die Antwort, aber das ändert nichts an dem Problem. Selber mal probiert? Auch wenn die APE-Tags ausgeschaltet sind, tritt es weiterhin auf.

Du musst die APE-Tags entfernen.

Guck mal, ob die Einstellungen bei dir mit denen in diesem Thread genannten übereinstimmen:

Funktioniert trotzdem nicht, mal selber probiert? Habe nun ALLE Tags entfernt und auch eine neue MP3 Datei von der WAV gemacht, nur um auf Nummer sicher zu gehen. Dann einfach nur versucht das Cover hinzuzufügen (genau wie im Video), Resultat genau das gleiche. Kann gerne ein neues Video davon machen.

Ja, Cover hinzufügen mache mache ich mit MP3Tag seit 1 Jahrzehnt (und auch heute und gestern) und wenn keine APE-Tags im Spiel sind, klappt das auch problemlos.

Eigentlich ständig, gerade eben zuletzt.
Was auffällt: du hast neben APE-Tags auch V2.4 tags im EInsatz. Darf man, kann aber z.B. der Windows Explorer (und damit WMP) nicht lesen.

Was aber vielleicht ein besserer Check wäre: was sagen denn die einschlägigen Überprüfungsprogramm wie mp3val und mp3diags zu den Dateien? Alles ok?

Ja, Dateien sind in Ordnung, auch wird ja in allen Programmen (WinAmp / FooBar2000, mein MP3 Player im Auto) das Cover ordentlich angezeigt. Nur MP3Tag selber zeigt es nach dem Einfügen nicht. Das ist schon eigenartig :wink: Letztendlich kann es mir ja egal sein, da es ja überall funktioniert, aber das sieht mir nach einem Bug in MP3Tag aus und deshalb habe ich es gemeldet.

Dass die Dateien abgespielt werden können, sagt gar nichts, sorry.
Wenn du schon vermutest, dass ein Bug vorliegt, dann wäre es nett, wenn du mithelfen würdest, einschlägig bekannte Fehlerursachen wie gestapelte Tags, unbekannte Streams, korrupte Header auszuschließen. Das ließe sich mit mit den genannten Programmen ruckzuck erledigen.
Denn was nützt es, etwas als Bug zu melden, was niemand nachvollziehen kann?

Das klingt tatsächlich sehr seltsam. Kannst Du mir die Kombination aus MP3 und Cover per PM oder Mail zukommen lassen? Dann schau ich mal rein :slight_smile:

Hi Florian,

gerne, der Mix wird heute ohnehin veröffentlicht. Hier der Link zu Google Drive

Edit: removed download link

nimm am besten die 128kbit Version wegen der Größe - alle MP3 Versionen sind betroffen (wie im Video zu sehen). Das problematische JPG-Cover habe ich als Anhang an diesen Post gehängt.

Viele Grüße :slight_smile:

Hi :slight_smile:

Hab mal reingeschaut und es ist wie von @ohrenkino und @poster beschrieben:

Die Datei hat APEv2 Tags, die jedoch kein Cover enthalten. Nachdem Mp3tag die Tags in der Reihenfolge
APEv2 > ID3v2 > ID3v1
anzeigt, wird bei Dir erstmal nur der APEv2 Tag angezeigt.

Wenn Du unter "Optionen > Tags > Mpeg" das Lesen von APEv2 deaktivierst und die Datei erneut auswählst, wird das Cover angezeigt (da nun der ID3v2 Tag gelesen wird).

Jetzt stellt sich noch die Frage, warum das Cover nicht auch in den APEv2 Tag gespeichert wird? Meine Vermutung ist, dass Du das Schreiben von APEv2 deaktiviert hast.

Ich empfehle Dir folgende Einstellungen:

  • Du wählst die Datei aus, dabei wird das Cover angezeigt (ID3v2)
  • Du entfernst alle Tags mittels Strg+R
  • Du machst das Entfernen Rückgängig via Strg+Z und lässt damit die Tags gemäß der Einstellungen schreiben.

Damit hat Deine Datei keine APEv2 Tags mehr und das Cover aus ID3v2 wird problemlos angezeigt.

@lvau du solltest deinen Erzeugungsprozess überprüfen, da anscheinend irgendein Programm APE-Tags anlegt.
MP3diags hätte dir übrigens mitgeteilt, dass (immer noch) APE-Tags in der Datei vorhanden sind. Und in MP3tag hättest du diesen Umstand vermutlich auch in der Kopfzeile des Dialogs "Erweiterte Tags" sehen können.
APE-Tags machen eine Datei nicht kaputt, aber sie führen oft zur Verwirrung, da viele Programme die Tags nicht synchronisieren beim Speichern und dann je nach Vorliebe beim Auslesen noch alte Daten zum Vorschein kommen bzw. Aktualisierungen fehlen.

OK, danke! Fürs nächste Mal dann, wird ja wie gesagt überall ordentlich abgespielt und angezeigt, auch mit dem APE Tag. War mir einfach nur komisch, warum MP3Tag das nicht hinbekommen hat und deshalb habe ich es gemeldet. Entferne ich die APE Tags, zeigt MP3Tag jetzt auch die Cover in der Vorschau an. Möchte die APE Tags aber gerne behalten und stellt wie gesagt für alle bisher getesteten Programme / Player kein Problem dar, zeigen alle das Cover an.

P.S.: Bei der Erstellung wurden auf jeden Fall keine Tags hinzugefügt, ist via command-line Lame 3.100 und definitiv ohne Tags. Dass die Datei "immer noch" APE Tags enthält, liegt daran, dass ich diese gestern Nacht dann einfach hochgeladen hatte, da wir veröffentlichen wollten. Ich habe hier Lokal gestern Nacht mit anderen Versionen der Dateien gearbeitet.