[X] leading zero WMA version 2.38


Was doing some more testing during posting the previous post and found also a problem with the WMA track numbering. Here I can change the number to one with a leading 0, but the number is not saved with a leading 0, unlike the MP4 problem. If I change the number with, say AudioShell, the number is saved with the leading 0 and MP3TAG displayes the leading 0 as well.


Edit: just to be sure I installed the latest build (2.38a), but w/o success, problem still there.

I have mp3tag 2.39 and was going to report this same issue, after doing a search I found this post. I like to have leading zero's in my track numbers but am unable to on wma files, mp3's work fine.

WinXP Home SP2

What happens if you delete the tag and write it back to the file using Edit > Undo. Can you then write tracknumbers with leading zeros?

It now looks like the problem is not limited to wma files, Today I have having the same problem with mp3's. With mp3's I have it set to write ID3v1 & ID3v2 tags and when the "ID3v2 only if ID3v1 too small" box is ticked it seems to refuse to put leading zeros on mp3 files. I'm not sure if the mp3 file need to have certain properties for this to happen (eg bit rate), I will check when I get a chance.

ID3v1 can't store tracknumbers with leading zeros. Please get the latest Development Build. It will write an ID3v2 tag if "ID3v2 only if ID3v1 too small" box is ticked and the tracknumbers contain leading zeros.

Just tried 2.39j with the "ID3v2 only if ID3v1 too small" box ticked. The "Auto Numbering Wizard" does not put leading zeros even though the "Leading Zeros for track numbers" box is ticked. Unticking the "ID3v2 only if ID3v1 too small" option and the "Auto Numbering Wizard" puts leading zeros as expected.

Also 2.39j has made itself the default application for all supported file. When I double click an mp3 or wma it opens it mp3 tag

P.S. I am having trouble reproducing my original error report (wma leading 0's). I will let you know if I run into the problem again.

My fault: I've mixed this with another change I made at this point. Mp3tag forces no ID3v2 tag for tracknumbers with leading zeros -- only for tracknumbers that contain total tracks.

Mp3tag does not do this by itself :slight_smile:

Not sure how all my files became associated with mp3tag (mpg files too), I could understand that I could have accidently associated 1 type with it but not all audio files and some video files too :wink: Fixed now anyway.

Back on topic, I found some wma's that would not take leading 0's. I tried the "Auto Numbering Wizard" and I tied converting "file name to tag", mp3tag reported that everything worked fine when actually none of this worked. It wasn't until I removed all tags from the files and then created them again using the undo function that it worked. I was then able to use either method mentioned earlier to create the leading 0's in the tag.

Some (broken) applications write the track number as a DWORD (a number format) whereas Mp3tag writes new track numbers as strings (like it's recommended in the specification).

The number format can't store leading zeros -- removing and resaving the tag writes the track number as a string which allows for leading zeros.

It's not a bug in Mp3tag.

Thanks for clearing that up. Would it be a worthwhile addition to mp3tag to have it detect this problem and either fix it or display a warning as opposed to saying everything worked fine when in fact it didn't ?

Good idea. I've changed this in the current Development Build.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.