Accent not found with %albumartist%

I am trying to create an new entry for the Tag->Tag conversions. The expression

$replace(%albumartist%,´,'')

does not work as intended. I can replace any other character with the apostrophe, but not the accent aigu.
On the other hand this expression (modified accordingly) works fine when I try use it within the %artist% field.
I don't understand why.

Try $replace(%albumartist%,'´','')

I had already done so, but just tried your suggestion again.
No good.
This is MP3Tag V. 3.02 on a German Win 10 (build 18363.959).
Can you reproduce it? Any further ideas?

Then I don't know what you tried.
I just tried
$replace(%albumartist%,'´',ö)
(to show that really something is found and replaced)
"Black Eyed Pea´s" -> "Black Eyed Peaös"

It may be worthwhile to copy&paste the character from one of the tracks where no match is found and try it with that.

Yup, that finally did it! Thank you!
Honestly - I should have thought of that myself. So obvious!
Now I wonder what weird character it really was, I was trying to replace. It sure looked like the accent.

It was char 92h = 146d -whatever that is called ...

92h is a so called "Right single quotation mark".
A simple ASCII table: https://www.ascii-code.com/

Some additional (german) explanations about the wrong use of apostrophes:

For completeness:

  • U+2019 RIGHT SINGLE QUOTATION MARK

Typographic ('curly') apostrophe. Serves as both an apostrophe and closing single quotation mark. This is the preferred character to use for apostrophe according to the Unicode standard.

Thank you. Nice to know - but if all of this is no bigger that a fly's shit, and has no direct keyboard representation, it sure get confusing!

1 Like