action does not work


#1

this does not work on any of my albums, why?

also if i generate an action with "format value" and change %track% to 0%track%
this also doesn't work.

can anybody help?

autonumbering works fine (ctrl-k) but not this actions.


#2

This may be the case if you have mp4 tags. They do not allow leading zeros for TRACK.


#3

no this is not the case, because autonumbering including leading zeros works well


#4

The expression you have used works for a single digit in the track field.
if you also have the total number behind the slash in the field, then it is a different pattern that does not match the search string in the regular expression.

Sorry, i did not read thorough enough

have you checked, if you have got another field with numbers in it if you look at the extended tags dialogue?
because: if you applied the action the way you described it, it should work.
But as typos may happen (the errorist wins) or you have used the letter o instead of the number zero - I cannot verify this from the distance - but this would explain it.


#5

no it's definitly the number 0, and i copy-pasted it from the above quote, which is exactly the regex i also found out befor i searched for a proper solution.
it seems to me that this actions-functionality doesn't work at all in my version of mp3tag

why should another filed with numbers in it affect this action which addresses only this special %track%-field?


#6

I tried to divert the view to the possibility that instead of the the field TRACK e.g. a field TRAK (or some other version of misspelling) has been treated.
So, e.g. if you format a field TRAK with 0%track% it naturally would not show as modification of TRACK ...
Just guessing.


#7

I have read about filetypes, which accepts as tracknumber only a numerical value, but not a numerical string:
(number) 1 vs. "01" (string, is not a number).

Please show us the actions.
Have a look at the function $num(value,width), which aligns the value at the left edge with character '0' up to 'width' size; as a sideeffect $num(value,1) removes all leading zeroes.

DD.20140904.1155.CEST


#8

ok, here some snapshots of the actions and the results, or better a video .....
bad that it's not allowed to upload a video file here.
so, here is a link to the videos, but ...... probably not forever reachable, bad for the forum here.
http://parafux.bplaced.net/downloads/
a picture shows more than thousand words, and a video shows more than thousand photos, cause they are :slight_smile:


#9

just a shot in the dark ...
... are there spaces at the left side of the track numbers?

If you do a preview and apply this formatstring ...
'#'%TRACK%'#'
... what do you see?

I am sure, that this formatstring will work for your example ...

$regexp($num(%TRACK%,1),'^(\d)$','0$1')

... same as ...

$num(%TRACK%,2)

DD.20140905.1739.CEST


#10

no there were no spaces inside the track number.

honestly i dont know, what went wrong, i created now the same filter from scratch again, and now it works.

so thread closed.

thx for trying to help me anyway.


#11
QUOTE ( @ Sep 14 2014, 14:39) <{POST_SNAPBACK}>
... i created now the same filter from scratch again, and now it works. ...

Filter - huh ???
It is the first time that the word filter in this thread shows up, and what does the Filter have to do with the initial problem?

DD.20140914.1515.CEST