Actions > Editing the format string

bug-fixed

#1

(Noticed in v2.91d, also reproduced in v2.93)

When editing a format string, in rare cases you are not given the actual string to start with, but an old string from the string history. I noticed this when I accidentally used uppercase, but I'm not sure if this issue is limited to uppercase/lowercase.

To reproduce, do the following

  1. Open Action groups, make an Action > Format value and type Field: ARTIST / Format string: Ringo STARR. Click all OK's.

  2. Open the Action again and edit from Ringo STARR to Ringo Starr. Click all OK's.

  3. Open and edit again and you'll see the discrepancy between Starr and STARR

I also tried to reproduce by misspelling Paul McCartney to Paul McCartnay, but everything was well, so maybe the bug is caused by uppercase/lowercase? It seems that variations of uppercase/lowercase are not saved in the string history.

Also, I wonder - does the edit string come from the history? Shouldn't it come from the saved Action? I mean, you normally have much more complex format strings than in my example above, and any history error would not be so easy to notice.

format%20string


#5

Thanks for reporting! I guess I've found the issue and will fix it to the next release.

And you've guessed correctly: it's related to uppercase/lowercase and happens only to those strings.


#6

I've fixed this with Mp3tag v2.93a. Thanks again for reporting!


#7

Thanks for the fix! I've tested and it's probably working as intended now. However, there's still a little trap:

After the fix, both Ringo Starr and Ringo STARR can appear simultaneously in the history. But if you delete Ringo Starr and miss to delete Ringo STARR, the latter will still be the proposed string when you edit. I think this is unfortunate, as running an Action can affect so much of your music library.

To avoid this I suggest an option to disable the history. Or perhaps a possibility to edit and lock the history to only keep valid strings and get rid of faulty strings and "testing junk strings" that have a tendency to build up.


#8

Thanks for confirming the fix!

I currently don't want to increase complexity by adding even more options. You can disable auto-completion at "Options > General" which should do the trick.


#9

Yes, but I do like the auto-completion at other places. Choices... :wink: