Adding lyrics not working

I only have FLAC (and a handful, less than a dozen out of 6000+, of mp3). I've checked the Poweramp version just to be sure, it reads V3, Full Version, 64 bit, build 905-uni. Interesting that converting the format, it DOES display the lyrics. I don't have dbPoweramp to convert between formats. It is at all possible that there are different 'flavors' of FLAC, that might account for the discrepancy between two different files, both supposedly FLAC?

Couldn't you supply a working file so that others could have a look at it?

I have this from my side...


...which shows the only tag type is FLAC as expected, and only a single field for UNSYNCEDLYRICS.

And the file properties don't have anything that stand out differently either. It is a standard 16 bit/44.1kHz FLAC file.

FLAC often uses LYRICS instead of UNSYNCEDLYRICS, maybe worth trying.

1 Like

I wonder why it is so difficult to supply a working file.

Also, it may be worth a look to see if there were any mappings in Tools>Options>Tags>Mapping.
Perhaps these have disappeared with an update.

I thought you could only add lyrics using UNSYNCEDLYRICS, that LYRICS was reserved for lyrics that came embedded in the file (i.e. present on a purchased CD for example, or a purchased download?

It's not difficult at all... I thought I had sent a working and a non-working file. Looking back, I see the link I sent only points to the non-working file. Here is a link to the working file I thought I had sent (lyrics added a couple of years ago, but all of the software/firmware/hardware the same as now): working file
My bad!

And I have JUST discovered something! I went back and tried adding a lyric to one of the problem files using the LYRICS tag (which I have to type in as it doesn't show on the drop-down) rather than the UNSYNCEDLYRICS tag, and it works! I thought that was reserved, thus requiring the use of the UNSYNCEDLYRICS tag. So the solution seems to be to use the LYRICS tag, at least with FLAC files.

I want to thank everyone who has taken the time to troubleshoot this issue, much appreciated!
Regards,
Mark

So just to confirm, in all of your older, working FLAC files these were properly stored in the LYRICS field. And for all the files that weren’t working, you had stored them in the UNSYNCEDLYRICS field. So moving them all to LYRICS has corrected the issue?

Not exactly. Previous to this month, I added lyrics USING the UNSYNCEDLYRICS tag, prefaced with eng|| . With the files I've been working with this week, that did not work. However, entering the text in the LYRICS tag (w/o the eng|| prefix) has solved the problem. All of the older files continue to work as they always have, no moving from one tag to the other.

It seems to me that you have no field mapping for LYRICS to UNSYNCEDLYRICS defined in Tools->Options->>Tags->Mappings, that you had in the past maybe after an update.
Which version of MP3Tag do you have installed, 64 bit or 32 bit?
There was a potentially problem with corrupting previous field-mappings and the new 64 bit version.

3.14f (2022-05-07)

  • FIX: potential data corruption when reading and saving configuration lists, e.g., field mappings or filter histories on 64-bit (since v3.14e). Please restore from backup before proceeding with v3.14f.

Read about mappings:
https://docs.mp3tag.de/customization/options/tags/mapping/

1 Like

When I look at this file with Foobar and MP3tag it shows 2 fields for lyrics:
LYRICS
UNSYNCEDLYRICS

So I doubt that the original claim

is really correct.

1 Like