Adding missing cover fails to find any jpg files


#1

I loaded some new MP3s and they had no cover. So I did the following:

  1. Right clicked on "Empty" cover in lower left corner of MP3Tag
  2. clicked add cover
  3. MP3TAG brought up Windows Explorer & I navigated to the source folder of the new MP3s.
  4. That folder contains several jpgs of different sizes for the album
  5. HERE is the problem: even though the search is for (*.jpg; *.jpeg; *.png), NONE of these were made available or visible.
  6. What am I doing wrong.??

I since went to a long round about method of going to Menu>Tag Sources>Amazon.com then selected the album, then copy and pasted the tracks.
That worked but seems very laborious.

Thanks
JCalvert


#2

I had the same problem today for the first time.
My solution was to remove id3v1 tag and have only the id3v2 tags in the mp3 files. (use tools and options select write only id3v2 - then delete tag - a little scary but it works!)
Then I could add jpg covers as I have done at least 1000 times before.
I could not even do it by the Amazon route as you describe.
My MP3's were ripped by windows media player which I use because it gives good automatic tagging including covers - they are not embedded though.


#3
  1. Only id3v1 do not support artwork.
  2. You can open windows explorer and drag the artwork to the missing artwork area of the program.

#4

An alternative to dragging and dropping is to COPY an image (from the net or another program e.g. image editing program and then RIGHT CLICK the image window in mp3tag and select Paste cover. Doing it this way means that you don't have to create an intermediary file between source and destination. :wink:


#5

But you should know that's not a lossless process. The image is re-encoded to jpg