Advice about autonumbering

I am probably doing something (or not doing) silly, but Im doing a major tag review of my music collection and would like to fill in the gaps on some albums with no track numbering with the autonumbering wizard - but when I select the files and choose autonumbering nothing is happening when I press ok on the dialog box. Am I missing an obvious step here?

Where do you expect something to happen?

And as no-one from the distance can look over your shoulder you have to offer some more information like

  • a screenshot of the settings in the autonumbering wizard,
  • a screenshot of the extended tags dialogue of a single file
  • a screenshot of the options Ctrl-O in Tags>Mpeg

autonumber two extended tags of file

autonumber 3 tag options

Please see screenshots as suggested. I thought after selecting the files and parameters in the autonumbering dialog box it was simply a case of pressing ok, but perhaps the screenshots might give a clue as to why nothing happens...

It looks ok to me. everything.
As these are FLAC files, it could still be that you have a mapping in the Options>Tags>Mapping - but that should still not really effect the display in the extended tags dialogue.
Can you add any other field to the files?
Or can no metadata be added to the files at all?

This part of the Wizard may be causing the problem.

Since you don't have a disc number in your current tags, there is nothing to reset them. I would try unchecking that first box, instead check the box for "Reset disc counter on change of" and in that list choose directory (if that applies) or maybe even choose ALBUM there instead.

Ok thanks for suggestions - I got it to work by checking id3v1 write box in this dialog box


Strange that this would have any influence on a FLAC file. :thinking:

That does not really make sense if you tag FLAC files as those settings are intended for WavPack, Musepack and other file formats that use APE tags.
FLAC files use Vorbis Comments.

What would have been the answer to my question whether you could create other fields before you modified the settings?
I suspect that something else could be wrong with these files.

Yes I was able to create other tag fields without a problem, but it was only when I checked that particular ID3v1 option did the autonumbering spring into life. Oh well its working now and as Im a great fan of MP3tag Im not going to worry too much about why this worked