[AF] ID3 Tags werden nur in erste Datei der Auswahl geschrieben


#1

Hallo zusammen,

ich habe mit Mp3tag ca. 400 Alben problemlos bearbeitet, lief super. :w00t:

Jetzt habe ich aber ein neues Verhalten: Ich markiere alle MP3 Dateien eines Albums (z.B. 10 Dateien mit Klick und Shift-Klick, werden dann blau hinterlegt), wähle Tag-Quellen -> Amazon.de -> ... -> Anpassen der ermittelten Informationen (Fenster mit Albuminformationen) -> OK. Dann zeigt Mp3tag den Schreibfortschrittsdialog mit "... 1 von 1 ..." an und schreibt die Tags tatsächlich nur in die erste Datei der Auswahl. Die anderen 9 markierten Dateien werden nicht angefasst.

Bug oder Benutzerfehler?

Die MP3s haben bereits Tags (laut Tag Spalte "ID3v2.3 (ID3v1, ID2v2.3)").

Vielen Dank,
Bernd


#2

Hallo Bernd,

kannst Du bitte versuchen zu beschreiben ob und wie der Fehler reproduzierbar ist?

Viele Grüße
Florian


#3

Nabend zusammen,

ich habe jetzt mal ein wenig rumgetestet und habe eine Vermutung:

Dieses verhalten tritt auf wenn im Dialog "Anpassen der ermittelten Information" in der Liste "Zusätzliche Informationen" der TITLE Tag Fragezeichen enthält.

Test:

Die MP3s mit denen ich die Probleme habe lassen sich problemlos mit Tags von irgendeinem Album, geholt von amazon.de, beschreiben.

Andere MP3s mit denen ich beim Taggen keine Probleme habe zeigen das Problemverhalten wenn ich von amazon.de Daten mit Fragezeichen im TITLE Tag hole.

Reproduzieren mit 2.46b:

Irgendwelche MP3s nehmen, markieren, Tag-Quellen -> Amazon.de, Im "Suche in" Dialog "die rätselhaften Bilder" eingeben, im Suchergebnis den ersten Treffer wählen, Weiter, OK. Ergebnis: nur die erste Datei wird angefasst.

Ich habe versucht im Amazon.de Script das TITLE Tag abzukelmmen aber dazu reichen meine Kentnisse zur Scipt-Syntax nicht aus...

Viele Grüße,
Bernd


#4

Den Titel kannst du loswerden wenn du am Ende vom Script
set "tracks"
schreibst.

Musicbrainz ist auch eine Alternative.


#5

Musicbrainz kennt aber nicht "Die drei???" :laughing:

Viele Grüße,
Bernd


#6

Doch natürlich.
Suche nach "die rätselhaften Bilder"
http://musicbrainz.org/album/944a67ef-7fc0...1ab79f8855.html
alle Alben:
http://musicbrainz.org/artist/e028fab5-39a...344d88b171.html


#7

Schaue dir mal die folgende Tool Definition an, mit der bei Google gesucht wird.
Das nur als ein Beispiel. Fällt dir etwas Besonderes auf?

Name: Google Images
Pfad: C:\Programme\Internet Explorer\iexplore.exe
Parameter: 'http://www.google.com/images?q='$replace(%artist%' '%title%,' ','+','?','%3F')

Um es einfach zu sagen ...
Da gibt es bei dem URL ein Fragezeichen, und das hat eine besondere Steuerungsfunktion für die Abfrage beim Webserver.
Weitere Fragezeichen bei dieser "Web Kommandozeile" müssen deshalb "eskapiert" werden, damit der Webserver sie nicht als Kommandozeichen, sondern als Literal verstehen kann.

So kann man nach "die drei ???" suchen ...
http://www.google.com/images?q=die+drei+%3F%3F%3F
... und Treffer haben.

DD.20100918.1306.CEST


#8

Dieses Ersetzen wird bei der Tag-Quelle automatisch vorgenommen, auch "die drei ???" liefert bei MB Treffer.


#9

Hallo zusammen,

vielen Dank für die Antworten.

MusicBrainz hat tatsächlich mein unmittelbares Problem gelöst. Ich hatte wohl damals einen Schreibfehler in meiner Suche.

Allerdings glaube ich immer noch dass der Amazon.de Tag-Reader ein Problem mit diesen Tags hat.

Zur Erläuterung des Fehlerbildes: Nicht das Lesen von Amazon.de ist das Problem, die Informationen kommen sauber in Mp3Tag an, inklusive Fragezeichen. Das Problem ist das Schreiben in die MP3-Datei (beziehungsweise das Nicht-Schreiben...).

Viele Grüße,
Bernd


#10

Da das Album bei Amazon nur einen Track hat wird nur eine Datei verändert.
Man kann das zwar ändern, dass einfach alle Dateien getaggt werden, das kann aber zu anderen Nebeneffekten führen.


#11

Die Trackliste zeigt aber keinen Track an, oder? Wenn ein Track angezeigt würde, dann könnte man im Dialog zuordnen oder sehen dass es nicht passt.

Mit null Dateien in der Trackliste hat Mp3tag bisher/vorher immer die Album-Daten (Interpret, Album, Cover,..) geschrieben.

Viele Grüße,
Bernd