[AF] Websource und aktivierter debug-mode

Ich wollte eine Musicbrainz-Websource von dano anpassen und machte nichts anderes, als die paar
#debug
und
#debugwriteinput
zu aktivieren (= # entfernen) um zu sehen, was da genau daherkommt.

Das führt mit der sonst unveränderten Source zu:

---------------------------
Mp3tag v2.43a
---------------------------
Schwerer Ausnahmefehler

Datei:    .\mtonlinehandler.cpp
Zeile:    606

Die Anwendung befindet sich in einem undefinierten Zustand.
Schließen Sie die Anwendung und übermitteln Sie die
Datei

C:\Users\LyricsLover\AppData\Roaming\Mp3tag\Mp3tagError.log

sowie eine möglichst genaue Beschreibung der Fehlerentstehung
an den Support.

eMail: support@mp3tag.de
---------------------------
OK   
---------------------------

Das erwähnte Mp3tagError.log enthält folgende Zeilen:

================================================================================
Mp3tag v2.43a - 12.07.2009 - 15:37:21
--------------------------------------------------------------------------------
OS-Version: Windows Vista Service Pack 2 (Build 6002)
--------------------------------------------------------------------------------
Build: Jun  6 2009 16:44:20
--------------------------------------------------------------------------------
AppPath:  226.587.426.816 Bytes frei (C:\Program Files (x86)\Tools\Sound\Mp3tag\)
DataPath: 226.587.426.816 Bytes frei (C:\Users\LyricsLover\AppData\Roaming\Mp3tag\data\)
TempPath: 226.587.426.816 Bytes frei (C:\Users\LyricsLover\AppData\Local\Temp\Mp3tag v2.43a\)
================================================================================

--------------------------------------------------------------------------------
THROW
--------------------------------------------------------------------------------
File:        .\sparser.cpp
Line:        993
--------------------------------------------------------------------------------
CATCH
--------------------------------------------------------------------------------
File:        .\mtonlinehandler.cpp
Line:        606
================================================================================

Könntest Du bitte mal die Web Source hier verlinken und die Sucheingabe die den Fehler produziert auch mit angeben.

Quelle: http://forums.mp3tag.de/index.php?act=atta...ost&id=2609

Ich hab die Websource
'MusicBrainz Web Service22#Search by Album + Artist (+ID Tags).src"
aus dem Zipfile
MusicBrainz_Web_Service22.zip
verwendet. Die einzige Anpassung die ich an der *.src machte:

debug "on" "c:\Debug\MusicBrainz_XML2_A.html" "2"
debugwriteinput "c:\Debug\MusicBrainz XML2.xml"

debug "on" "c:\Debug\MusicBrainz_XML2-B.html" "5"
debugwriteinput "C:\Debug\MusicBraniz XML2 B.xml"

Beim Beschreiben dieses Fehlers kam ich selber auf die Ursache:
Das Verzeichnis C:\Debug existierte (noch) nicht und konnte anscheinend auch nicht erstellt werden (obwohl ich als Vista-Admin angemeldet bin).

Jetzt muss ich nur noch rausfinden, wo die Debug-Dateien tatsächlich hingeschrieben werden - ins manuell erstellte C:\Debug wird auf jeden Fall nichts geschrieben - oder sofort gelöscht.