After open mp3tag app,I can't edit those music tags by anyother software!

As you see, I can't edit tags by the explorer of windows10, which should can before I ran mp3tag.
I also tried to edit those music by other software just like groove music and some others, and they dosen't work.
Now I have the only way to edit must tags is using mp3tag,

check which tag encoding you use: Tools>Options>Tags>Mpeg ... UTF should be the selected option.
see if the access rights are ok.

see if your files are OK.
Check them with mp3val, foobar2000 and/or mp3diags if they are mp3 files.

image
The encoding is UTF-16 by default, and I also gave the users user-group writing access just like this file:


All music file types which's tags could be edited by mp3tag now are unable to be edited by anyother software, even they are downloaded only a moment ago and never be edited by mp3tag!
If it's the problem of music files themselves, why the mp3tag is able to edit them? It's so strange, I tried everything I found but nothing work.
By the way, I have installed mp3tag in portable mode, so I don't think uninastll it could take effect.

OK, I dowloaded foobar2000 under your advice, and It's working!
Thank you very much. Although my windows explorer/groove music/and some other autochthonous music players still don't work, anyway, at least I knew It's not the mp3tag's cause, and it's enough.
Maybe it's a bug of windows's build-in encoding, who konws, who cares.